summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-06-24 20:35:14 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-06-24 20:35:14 +0000
commite0d10d6381ad1afb6f5faf54d17f28d50b9a513a (patch)
treec33f16ea938ea7edee462e3b88adf72de5f022f1 /dev-python
parentDropped old versions (diff)
downloadgentoo-2-e0d10d6381ad1afb6f5faf54d17f28d50b9a513a.tar.gz
gentoo-2-e0d10d6381ad1afb6f5faf54d17f28d50b9a513a.tar.bz2
gentoo-2-e0d10d6381ad1afb6f5faf54d17f28d50b9a513a.zip
Fixed $ROOT abuse (bug #167271), cleanup, dropped old versions
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/astng/ChangeLog7
-rw-r--r--dev-python/astng/astng-0.16.0.ebuild55
-rw-r--r--dev-python/astng/astng-0.16.1.ebuild57
-rw-r--r--dev-python/astng/astng-0.16.3.ebuild57
-rw-r--r--dev-python/astng/astng-0.17.0.ebuild16
-rw-r--r--dev-python/astng/files/astng-0.16.0-revert-test.patch20
-rw-r--r--dev-python/astng/files/digest-astng-0.16.03
-rw-r--r--dev-python/astng/files/digest-astng-0.16.13
-rw-r--r--dev-python/astng/files/digest-astng-0.16.33
9 files changed, 15 insertions, 206 deletions
diff --git a/dev-python/astng/ChangeLog b/dev-python/astng/ChangeLog
index 5e101ab293c3..febed7fdb7fb 100644
--- a/dev-python/astng/ChangeLog
+++ b/dev-python/astng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/astng
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.19 2007/05/20 08:47:59 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.20 2007/06/24 20:35:14 dev-zero Exp $
+
+ 24 Jun 2007; Tiziano Müller <dev-zero@gentoo.org>
+ -files/astng-0.16.0-revert-test.patch, -astng-0.16.0.ebuild,
+ -astng-0.16.1.ebuild, -astng-0.16.3.ebuild, astng-0.17.0.ebuild:
+ Fixed $ROOT abuse (bug #167271), cleanup, dropped old versions
20 May 2007; Christian Faulhammer <opfer@gentoo.org> astng-0.17.0.ebuild:
stable amd64, bug 176201
diff --git a/dev-python/astng/astng-0.16.0.ebuild b/dev-python/astng/astng-0.16.0.ebuild
deleted file mode 100644
index a6387caee65c..000000000000
--- a/dev-python/astng/astng-0.16.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.16.0.ebuild,v 1.2 2006/08/02 03:26:24 tgall Exp $
-
-inherit distutils eutils
-
-DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
-SRC_URI="ftp://ftp.logilab.org/pub/astng/${P}.tar.gz"
-HOMEPAGE="http://www.logilab.org/projects/astng/"
-
-IUSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-LICENSE="GPL-2"
-DEPEND=">=dev-lang/python-2.1
- >=dev-python/logilab-common-0.13-r1"
-
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # 0.16.0 introduces a (most likely intentionally) failing test, revert it
- # to the (passing) 0.15.0 version.
- epatch "${FILESDIR}/${P}-revert-test.patch"
-}
-
-src_install() {
- distutils_src_install
- python_version
- # we need to remove this file because it collides with the one
- # from logilab-common (which we depend on).
- rm "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/logilab/__init__.py"
-}
-
-src_test() {
- # The tests will not work properly from the source dir, so do a
- # temporary install.
-
- python_version
- local spath="usr/$(get_libdir)/python${PYVER}/site-packages/"
- # This is a hack to make tests work without installing to the live
- # filesystem. We copy part of the logilab site-packages to a temporary
- # dir, install there, and run from there.
- mkdir -p "${T}/test/${spath}/logilab"
- cp -r "${ROOT}${spath}/logilab/common" "${T}/test/${spath}/logilab" \
- || die "copying logilab-common failed!"
-
- "${python}" setup.py install --root="${T}/test" || die "test copy failed"
- # dir needs to be this or the tests fail
- cd "${T}/test/${spath}/logilab/astng/test"
- PYTHONPATH="${T}/test/${spath}" "${python}" runtests.py \
- || die "tests failed"
- cd "${S}"
- rm -rf "${T}/test"
-}
diff --git a/dev-python/astng/astng-0.16.1.ebuild b/dev-python/astng/astng-0.16.1.ebuild
deleted file mode 100644
index 037417f1a05a..000000000000
--- a/dev-python/astng/astng-0.16.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.16.1.ebuild,v 1.1 2006/09/26 23:56:29 marienz Exp $
-
-inherit distutils eutils
-
-DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
-SRC_URI="ftp://ftp.logilab.org/pub/astng/${P}.tar.gz"
-HOMEPAGE="http://www.logilab.org/projects/astng/"
-
-IUSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-LICENSE="GPL-2"
-DEPEND=">=dev-lang/python-2.1
- >=dev-python/logilab-common-0.13-r1"
-
-S="${WORKDIR}/logilab-${P}"
-
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Skip a failing test.
- epatch "${FILESDIR}/${P}-skip-gobject-test.patch"
-}
-
-src_install() {
- distutils_src_install
- python_version
- # we need to remove this file because it collides with the one
- # from logilab-common (which we depend on).
- rm "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/logilab/__init__.py"
-}
-
-src_test() {
- # The tests will not work properly from the source dir, so do a
- # temporary install.
-
- python_version
- local spath="usr/$(get_libdir)/python${PYVER}/site-packages/"
- # This is a hack to make tests work without installing to the live
- # filesystem. We copy part of the logilab site-packages to a temporary
- # dir, install there, and run from there.
- mkdir -p "${T}/test/${spath}/logilab"
- cp -r "${ROOT}${spath}/logilab/common" "${T}/test/${spath}/logilab" \
- || die "copying logilab-common failed!"
-
- "${python}" setup.py install --root="${T}/test" || die "test copy failed"
- # dir needs to be this or the tests fail
- cd "${T}/test/${spath}/logilab/astng/test"
- PYTHONPATH="${T}/test/${spath}" "${python}" runtests.py \
- || die "tests failed"
- cd "${S}"
- rm -rf "${T}/test"
-}
diff --git a/dev-python/astng/astng-0.16.3.ebuild b/dev-python/astng/astng-0.16.3.ebuild
deleted file mode 100644
index 2db6b9417dd3..000000000000
--- a/dev-python/astng/astng-0.16.3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.16.3.ebuild,v 1.1 2006/11/29 23:58:18 marienz Exp $
-
-inherit distutils eutils
-
-DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
-SRC_URI="ftp://ftp.logilab.org/pub/astng/logilab-${P}.tar.gz"
-HOMEPAGE="http://www.logilab.org/projects/astng/"
-
-IUSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-LICENSE="GPL-2"
-DEPEND=">=dev-lang/python-2.1
- >=dev-python/logilab-common-0.13-r1"
-
-S="${WORKDIR}/logilab-${P}"
-
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Skip a failing test.
- epatch "${FILESDIR}/${PN}-0.16.1-skip-gobject-test.patch"
-}
-
-src_install() {
- distutils_src_install
- python_version
- # we need to remove this file because it collides with the one
- # from logilab-common (which we depend on).
- rm "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/logilab/__init__.py"
-}
-
-src_test() {
- # The tests will not work properly from the source dir, so do a
- # temporary install.
-
- python_version
- local spath="usr/$(get_libdir)/python${PYVER}/site-packages/"
- # This is a hack to make tests work without installing to the live
- # filesystem. We copy part of the logilab site-packages to a temporary
- # dir, install there, and run from there.
- mkdir -p "${T}/test/${spath}/logilab"
- cp -r "${ROOT}${spath}/logilab/common" "${T}/test/${spath}/logilab" \
- || die "copying logilab-common failed!"
-
- "${python}" setup.py install --root="${T}/test" || die "test copy failed"
- # dir needs to be this or the tests fail
- cd "${T}/test/${spath}/logilab/astng/test"
- PYTHONPATH="${T}/test/${spath}" "${python}" runtests.py \
- || die "tests failed"
- cd "${S}"
- rm -rf "${T}/test"
-}
diff --git a/dev-python/astng/astng-0.17.0.ebuild b/dev-python/astng/astng-0.17.0.ebuild
index 2e5e4af24e77..ae32358f98c7 100644
--- a/dev-python/astng/astng-0.17.0.ebuild
+++ b/dev-python/astng/astng-0.17.0.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.17.0.ebuild,v 1.4 2007/05/20 08:47:59 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.17.0.ebuild,v 1.5 2007/06/24 20:35:14 dev-zero Exp $
-inherit distutils eutils
+NEED_PYTHON=2.1
+
+inherit distutils eutils multilib
DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
SRC_URI="ftp://ftp.logilab.org/pub/astng/logilab-${P}.tar.gz"
@@ -12,11 +14,11 @@ IUSE=""
SLOT="0"
KEYWORDS="amd64 ~ia64 ppc ~ppc64 ~sparc x86"
LICENSE="GPL-2"
-DEPEND=">=dev-lang/python-2.1
- >=dev-python/logilab-common-0.13-r1"
-S="${WORKDIR}/logilab-${P}"
+DEPEND=">=dev-python/logilab-common-0.13-r1"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/logilab-${P}"
src_unpack() {
unpack ${A}
@@ -47,14 +49,14 @@ src_test() {
# filesystem. We copy part of the logilab site-packages to a temporary
# dir, install there, and run from there.
mkdir -p "${T}/test/${spath}/logilab"
- cp -r "${ROOT}${spath}/logilab/common" "${T}/test/${spath}/logilab" \
+ cp -r "/${spath}/logilab/common" "${T}/test/${spath}/logilab" \
|| die "copying logilab-common failed!"
"${python}" setup.py install --root="${T}/test" || die "test copy failed"
# Use a hacked up copy of pytest that exits nonzero on failure.
sed -e 's/exitafter=False/exitafter=True/' \
- < "${ROOT}usr/bin/pytest" > "${T}/pytest" || die "sed failed"
+ < "/usr/bin/pytest" > "${T}/pytest" || die "sed failed"
# Pytest picks up tests relative to the current dir, so cd in.
pushd "${T}/test/${spath}/logilab/astng" >/dev/null
diff --git a/dev-python/astng/files/astng-0.16.0-revert-test.patch b/dev-python/astng/files/astng-0.16.0-revert-test.patch
deleted file mode 100644
index b2f987438d88..000000000000
--- a/dev-python/astng/files/astng-0.16.0-revert-test.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-=== modified file 'a/test/unittest_builder.py'
---- a/test/unittest_builder.py
-+++ b/test/unittest_builder.py
-@@ -159,11 +159,10 @@
- def test_socket_build(self):
- import socket
- astng = self.builder.module_build(socket)
-- for fclass in astng.igetattr('socket'):
-- print fclass.root().name, fclass.name, fclass.lineno
-- self.assert_('connect' in fclass)
-- self.assert_('send' in fclass)
-- self.assert_('close' in fclass)
-+ fclass = astng.igetattr('socket').next()
-+ self.assert_('connect' in fclass)
-+ self.assert_('send' in fclass)
-+ self.assert_('close' in fclass)
-
-
- class FileBuildTC(TestCase):
-
diff --git a/dev-python/astng/files/digest-astng-0.16.0 b/dev-python/astng/files/digest-astng-0.16.0
deleted file mode 100644
index 435cd900a7b3..000000000000
--- a/dev-python/astng/files/digest-astng-0.16.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 636b57a742ad5d9cb030429eca9841e9 astng-0.16.0.tar.gz 54410
-RMD160 7c9226adc2fd1ad5fa1c74ac1cfb9436927c0273 astng-0.16.0.tar.gz 54410
-SHA256 33b1da358d2ec24f00623da8dcc3aaf5f8e04772c9b26930fc80bef72a9ad654 astng-0.16.0.tar.gz 54410
diff --git a/dev-python/astng/files/digest-astng-0.16.1 b/dev-python/astng/files/digest-astng-0.16.1
deleted file mode 100644
index c37a9dcafd03..000000000000
--- a/dev-python/astng/files/digest-astng-0.16.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 ac1ff0dd80dca7850413ccfbbf638fd7 astng-0.16.1.tar.gz 61180
-RMD160 af1369e73471f97c37222e6bef34eeac21412291 astng-0.16.1.tar.gz 61180
-SHA256 116285f2a566a75df3c998e37d245bd26c3ade6cbc320a97aea750ae05196c5f astng-0.16.1.tar.gz 61180
diff --git a/dev-python/astng/files/digest-astng-0.16.3 b/dev-python/astng/files/digest-astng-0.16.3
deleted file mode 100644
index 44b550ed8690..000000000000
--- a/dev-python/astng/files/digest-astng-0.16.3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 12061e3f8accd115ba101c6af15e5eef logilab-astng-0.16.3.tar.gz 58548
-RMD160 7fb40a0c2d1264f788c9bc903b58c88cfc32c3fd logilab-astng-0.16.3.tar.gz 58548
-SHA256 e1f418eeed96c2831215bbf76c7df395b23b699c08a13350974147dfb67acb43 logilab-astng-0.16.3.tar.gz 58548