summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-30 09:37:14 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-30 09:37:14 +0000
commitdb121c44e546b75eb2f0951590c211c990944bb6 (patch)
tree6ac628df3fff01860146652da44afc22c8d451a1 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-db121c44e546b75eb2f0951590c211c990944bb6.tar.gz
gentoo-2-db121c44e546b75eb2f0951590c211c990944bb6.tar.bz2
gentoo-2-db121c44e546b75eb2f0951590c211c990944bb6.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests/ChangeLog8
-rw-r--r--dev-python/requests/requests-0.14.2.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-python/requests/ChangeLog b/dev-python/requests/ChangeLog
index fff495ec0904..967124a55f17 100644
--- a/dev-python/requests/ChangeLog
+++ b/dev-python/requests/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/requests
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.22 2012/10/06 02:03:36 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.23 2012/10/30 09:37:14 patrick Exp $
+
+*requests-0.14.2 (30 Oct 2012)
+
+ 30 Oct 2012; Patrick Lauer <patrick@gentoo.org> +requests-0.14.2.ebuild,
+ requests-0.14.1.ebuild:
+ Bump
06 Oct 2012; Anthony G. Basile <blueness@gentoo.org> requests-0.14.1.ebuild:
keyword ~arm, bug #437250
diff --git a/dev-python/requests/requests-0.14.2.ebuild b/dev-python/requests/requests-0.14.2.ebuild
new file mode 100644
index 000000000000..689289ef5ac5
--- /dev/null
+++ b/dev-python/requests/requests-0.14.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-0.14.2.ebuild,v 1.1 2012/10/30 09:37:14 patrick Exp $
+
+EAPI="4"
+PYTHON_DEPEND="*:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="app-misc/ca-certificates
+ dev-python/chardet
+ dev-python/oauthlib
+ dev-python/urllib3"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES=1
+
+# tests connect to various remote sites
+RESTRICT="test"
+
+src_prepare() {
+ # use system libs for chardet, oauthlib, and urllib3
+ rm -r requests/packages || die
+ epatch "${FILESDIR}"/${PN}-0.14.1-system-libs.patch
+
+ # use system ca-certificates
+ rm requests/cacert.pem || die
+ epatch "${FILESDIR}"/${PN}-0.14.1-system-cacerts.patch
+
+ # Different packages are installed depending on the python version.
+ # Need to remove stale egg-info data and build in separate directories.
+ rm -r requests.egg-info || die
+
+ distutils_src_prepare
+}
+
+src_test() {
+ echoit() { echo "$@"; "$@"; }
+ testing() {
+ echoit nosetests --verbosity=1 tests/*.py
+ }
+ python_execute_function testing
+}