summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2004-03-16 03:39:36 +0000
committerChris PeBenito <pebenito@gentoo.org>2004-03-16 03:39:36 +0000
commitd083a9cecb33dc61ac40697ea49cab93e6bcdfac (patch)
tree3afc9ba8e6701f178900c66545ae36a4c7bd792f /dev-python
parentAdded ~mips keyword. (Manifest recommit) (diff)
downloadgentoo-2-d083a9cecb33dc61ac40697ea49cab93e6bcdfac.tar.gz
gentoo-2-d083a9cecb33dc61ac40697ea49cab93e6bcdfac.tar.bz2
gentoo-2-d083a9cecb33dc61ac40697ea49cab93e6bcdfac.zip
New release. Fixes for newer is_selinux_enabled() behavior.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-selinux/ChangeLog10
-rw-r--r--dev-python/python-selinux/files/digest-python-selinux-2.120
-rw-r--r--dev-python/python-selinux/files/python-selinux-2.12.c.bz2bin0 -> 5621 bytes
-rw-r--r--dev-python/python-selinux/python-selinux-2.12.ebuild36
4 files changed, 44 insertions, 2 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index fde498a9c94b..eeb6c63015ad 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-selinux
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.14 2003/12/07 00:59:49 pebenito Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.15 2004/03/16 03:39:36 pebenito Exp $
+
+*python-selinux-2.12 (15 Mar 2004)
+
+ 15 Mar 2004; Chris PeBenito <pebenito@gentoo.org>
+ python-selinux-2.12.ebuild, files/python-selinux-2.12.c.bz2:
+ New release. Fixes for newer is_selinux_enabled() behavior.
06 Dec 2003; Chris PeBenito <pebenito@gentoo.org>
python-selinux-2.10.ebuild:
diff --git a/dev-python/python-selinux/files/digest-python-selinux-2.12 b/dev-python/python-selinux/files/digest-python-selinux-2.12
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dev-python/python-selinux/files/digest-python-selinux-2.12
diff --git a/dev-python/python-selinux/files/python-selinux-2.12.c.bz2 b/dev-python/python-selinux/files/python-selinux-2.12.c.bz2
new file mode 100644
index 000000000000..12c6edf2c8b9
--- /dev/null
+++ b/dev-python/python-selinux/files/python-selinux-2.12.c.bz2
Binary files differ
diff --git a/dev-python/python-selinux/python-selinux-2.12.ebuild b/dev-python/python-selinux/python-selinux-2.12.ebuild
new file mode 100644
index 000000000000..8351f317f811
--- /dev/null
+++ b/dev-python/python-selinux/python-selinux-2.12.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.12.ebuild,v 1.1 2004/03/16 03:39:36 pebenito Exp $
+
+inherit python
+python_version
+
+DESCRIPTION="Python bindings for SELinux functions"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+
+DEPEND="dev-lang/python
+ sys-libs/libselinux"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ mkdir -p ${S}
+ bzcat ${FILESDIR}/${P}.c.bz2 > ${S}/selinux.c
+}
+
+src_compile() {
+ cd ${S}
+ einfo "Compiling selinux.so for python ${PYVER}"
+ gcc -fPIC -shared -o selinux.so -I /usr/include/python${PYVER}/ selinux.c -lselinux || die
+}
+
+src_install() {
+ insinto /usr/lib/python${PYVER}/site-packages
+ doins selinux.so
+}