summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-10-27 10:33:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-10-27 10:33:45 +0000
commitcb5a39d4f17901c2f46cb5fd53255d8eabaab974 (patch)
treee8e59f46af2954df5fdf6970c714f7ab242f87bf /dev-python
parentVersion bump and get rid of virtual/tetex (diff)
downloadgentoo-2-cb5a39d4f17901c2f46cb5fd53255d8eabaab974.tar.gz
gentoo-2-cb5a39d4f17901c2f46cb5fd53255d8eabaab974.tar.bz2
gentoo-2-cb5a39d4f17901c2f46cb5fd53255d8eabaab974.zip
Add a patch for compatibility with R-2.8.0
(Portage version: 2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rpy/ChangeLog6
-rw-r--r--dev-python/rpy/files/rpy-1.0.2-R28.patch13
-rw-r--r--dev-python/rpy/rpy-1.0.2-r1.ebuild5
3 files changed, 21 insertions, 3 deletions
diff --git a/dev-python/rpy/ChangeLog b/dev-python/rpy/ChangeLog
index 32c01ad03e19..36087abf1062 100644
--- a/dev-python/rpy/ChangeLog
+++ b/dev-python/rpy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/rpy
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/ChangeLog,v 1.27 2008/09/09 00:00:32 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/ChangeLog,v 1.28 2008/10/27 10:33:45 bicatali Exp $
+
+ 27 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/rpy-1.0.2-R28.patch, rpy-1.0.2-r1.ebuild:
+ Add a patch for compatibility with R-2.8.0
08 Sep 2008; Sébastien Fabbro <bicatali@gentoo.org> -rpy-0.4.6.ebuild:
Removed older version
diff --git a/dev-python/rpy/files/rpy-1.0.2-R28.patch b/dev-python/rpy/files/rpy-1.0.2-R28.patch
new file mode 100644
index 000000000000..47c4f5cf529e
--- /dev/null
+++ b/dev-python/rpy/files/rpy-1.0.2-R28.patch
@@ -0,0 +1,13 @@
+--- src/RPy.h.orig 2008-10-25 14:37:50.000000000 +0100
++++ src/RPy.h 2008-10-26 13:39:25.000000000 +0100
+@@ -74,8 +74,9 @@
+ # endif
+ #endif /* _WIN32 */
+
++#if R_VERSION < 133120
+ #include <Rdevices.h> /* must follow Graphics.h */
+-
++#endif
+
+ /* Missing definitions from Rinterface.h or RStartup.h */
+ # define CleanEd Rf_CleanEd
diff --git a/dev-python/rpy/rpy-1.0.2-r1.ebuild b/dev-python/rpy/rpy-1.0.2-r1.ebuild
index 797df23cb8da..4be15fa4c801 100644
--- a/dev-python/rpy/rpy-1.0.2-r1.ebuild
+++ b/dev-python/rpy/rpy-1.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-1.0.2-r1.ebuild,v 1.5 2008/09/01 13:01:44 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-1.0.2-r1.ebuild,v 1.6 2008/10/27 10:33:45 bicatali Exp $
inherit distutils eutils
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="amd64 ia64 x86"
IUSE="doc examples"
-RDEPEND=">=dev-lang/R-2.6.1
+RDEPEND="dev-lang/R
dev-python/numpy"
DEPEND="${RDEPEND}
doc? ( || ( virtual/texi2dvi ) )"
@@ -23,6 +23,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-1.0_rc3-version-detect.patch
epatch "${FILESDIR}"/${PN}-testfiles.patch
epatch "${FILESDIR}"/${P}-rpymodule-R-2.7.patch
+ epatch "${FILESDIR}"/${P}-R28.patch
# this module should exist only if R was built with USE=lapack
if [[ ! -e /usr/$(get_libdir)/R/lib/libRlapack.so ]]; then
sed -i \