summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-17 18:24:18 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-17 18:24:18 +0000
commitcb3f2b10c343a1bba503c56320c6c4ac12659dbd (patch)
treeda428e6b341035166cf1d7420f3a283c5549dd50 /dev-python
parentUse 'python_pkg_setup' instead of 'python_execute_function -f -q'. (diff)
downloadgentoo-2-cb3f2b10c343a1bba503c56320c6c4ac12659dbd.tar.gz
gentoo-2-cb3f2b10c343a1bba503c56320c6c4ac12659dbd.tar.bz2
gentoo-2-cb3f2b10c343a1bba503c56320c6c4ac12659dbd.zip
Delete older ebuild.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jinja2/jinja2-2.4.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/jinja2/jinja2-2.4.ebuild b/dev-python/jinja2/jinja2-2.4.ebuild
deleted file mode 100644
index f43de5e7bbf0..000000000000
--- a/dev-python/jinja2/jinja2-2.4.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja2/jinja2-2.4.ebuild,v 1.2 2010/04/13 16:45:53 arfrever Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils
-
-MY_PN="Jinja2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A small but fast and easy to use stand-alone template engine written in pure python."
-HOMEPAGE="http://jinja.pocoo.org/ http://pypi.python.org/pypi/Jinja2"
-SRC_URI="http://pypi.python.org/packages/source/J/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-IUSE="doc examples i18n test"
-
-RDEPEND="dev-python/setuptools
- i18n? ( >=dev-python/Babel-0.9.3 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )"
-
-S="${WORKDIR}/${MY_P}"
-
-DISTUTILS_GLOBAL_OPTIONS=("--with-speedups")
-DOCS="CHANGES"
-
-src_compile(){
- distutils_src_compile
-
- if use doc; then
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
- fi
-}
-
-src_install(){
- distutils_src_install
- python_clean_sitedirs
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- # Eliminate .pyc files going into /usr/share
- find examples -name "*.pyc" -print0 | xargs -0 rm -fr
-
- insinto "/usr/share/doc/${PF}"
- doins -r examples || die "Failed to install examples"
- fi
-}