summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-10-15 10:24:17 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-10-15 10:24:17 +0000
commitca455e9d8598b51df6439ca342a11ab37a863634 (patch)
treed17fd314fee4cb3f2cf894ac123660189ae00776 /dev-python
parent(#186802) Updates so the files are on mirrors. Also switch to using fedora-de... (diff)
downloadgentoo-2-ca455e9d8598b51df6439ca342a11ab37a863634.tar.gz
gentoo-2-ca455e9d8598b51df6439ca342a11ab37a863634.tar.bz2
gentoo-2-ca455e9d8598b51df6439ca342a11ab37a863634.zip
(#186802) Updates so the files are on mirrors. Also switch to using fedora-dev thirdpartymirrors setting to better find RPMs.
(Portage version: 2.1.3.13)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rhpl/ChangeLog8
-rw-r--r--dev-python/rhpl/files/digest-rhpl-0.2103
-rw-r--r--dev-python/rhpl/rhpl-0.210.ebuild49
3 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/rhpl/ChangeLog b/dev-python/rhpl/ChangeLog
index da7bcc2b9ace..5b13c9e172f1 100644
--- a/dev-python/rhpl/ChangeLog
+++ b/dev-python/rhpl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/rhpl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpl/ChangeLog,v 1.3 2007/10/15 09:45:34 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpl/ChangeLog,v 1.4 2007/10/15 10:24:17 dberkholz Exp $
+
+*rhpl-0.210 (15 Oct 2007)
+
+ 15 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>; +rhpl-0.210.ebuild:
+ (#186802) Updates so the files are on mirrors. Also switch to using
+ fedora-dev thirdpartymirrors setting to better find RPMs.
15 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>; rhpl-0.188.ebuild,
rhpl-0.208.ebuild:
diff --git a/dev-python/rhpl/files/digest-rhpl-0.210 b/dev-python/rhpl/files/digest-rhpl-0.210
new file mode 100644
index 000000000000..3a922605e226
--- /dev/null
+++ b/dev-python/rhpl/files/digest-rhpl-0.210
@@ -0,0 +1,3 @@
+MD5 35c86c8980ef6f9b45cfed9f4e571595 rhpl-0.210-1.src.rpm 304781
+RMD160 9b1bf4d72a355b7c07491055a3518f4d3290b6ee rhpl-0.210-1.src.rpm 304781
+SHA256 d22838a4b7d07ed3a504c600a9bb95df14405085d77df694f1833c8aa57f8ece rhpl-0.210-1.src.rpm 304781
diff --git a/dev-python/rhpl/rhpl-0.210.ebuild b/dev-python/rhpl/rhpl-0.210.ebuild
new file mode 100644
index 000000000000..97d4fcd9c3c3
--- /dev/null
+++ b/dev-python/rhpl/rhpl-0.210.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpl/rhpl-0.210.ebuild,v 1.1 2007/10/15 10:24:17 dberkholz Exp $
+
+inherit eutils multilib python rpm toolchain-funcs
+
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+DESCRIPTION="Library of python code used by Red Hat Linux programs"
+HOMEPAGE="http://fedoraproject.org/wiki/SystemConfig/"
+SRC_URI="mirror://fedora-dev/development/source/SRPMS/${P}-${RPMREV}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="dev-lang/python
+ !<sys-libs/libkudzu-1.2"
+DEPEND="${RDEPEND}
+ !s390? ( >=net-wireless/wireless-tools-28 )
+ sys-devel/gettext"
+
+src_unpack() {
+ rpm_src_unpack
+# epatch "${FILESDIR}"/${PV}-use-raw-strings-for-gettext.diff
+
+ sed -i \
+ -e 's:gcc:$(CC):g' \
+ "${S}"/src/Makefile
+}
+
+src_compile() {
+ python_version
+ emake \
+ PYTHON=python${PYVER} \
+ LIBDIR=$(get_libdir) \
+ ARCH=${ARCH} \
+ CC=$(tc-getCC) \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHON=python${PYVER} \
+ LIBDIR=$(get_libdir) \
+ install || die "emake install failed"
+}