summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2005-09-07 19:16:34 +0000
committerSimon Stelling <blubb@gentoo.org>2005-09-07 19:16:34 +0000
commitc799596e7356356cb8f4139fb26ed570d9be899f (patch)
tree38446cac6040cba3a2bca71ec65881e966a3646b /dev-python
parentStable on mips. (diff)
downloadgentoo-2-c799596e7356356cb8f4139fb26ed570d9be899f.tar.gz
gentoo-2-c799596e7356356cb8f4139fb26ed570d9be899f.tar.bz2
gentoo-2-c799596e7356356cb8f4139fb26ed570d9be899f.zip
make multilib-strict aware; bug 103535
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxpython/ChangeLog7
-rw-r--r--dev-python/wxpython/wxpython-2.4.2.4-r2.ebuild11
-rw-r--r--dev-python/wxpython/wxpython-2.4.2.4.ebuild7
-rw-r--r--dev-python/wxpython/wxpython-2.6.0.0-r1.ebuild6
-rw-r--r--dev-python/wxpython/wxpython-2.6.1.0.ebuild6
5 files changed, 22 insertions, 15 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index 39356d0bd658..ba6f5f1fd699 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wxpython
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.25 2005/07/12 18:48:03 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.26 2005/09/07 19:16:34 blubb Exp $
+
+ 07 Sep 2005; Simon Stelling <blubb@gentoo.org> wxpython-2.4.2.4.ebuild,
+ wxpython-2.4.2.4-r2.ebuild, wxpython-2.6.0.0-r1.ebuild,
+ wxpython-2.6.1.0.ebuild:
+ make multilib-strict aware; bug 103535
*wxpython-2.6.1.0 (12 Jul 2005)
diff --git a/dev-python/wxpython/wxpython-2.4.2.4-r2.ebuild b/dev-python/wxpython/wxpython-2.4.2.4-r2.ebuild
index c6df5bba17dd..ae8afa43a9ad 100644
--- a/dev-python/wxpython/wxpython-2.4.2.4-r2.ebuild
+++ b/dev-python/wxpython/wxpython-2.4.2.4-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.4.2.4-r2.ebuild,v 1.7 2005/06/17 20:28:29 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.4.2.4-r2.ebuild,v 1.8 2005/09/07 19:16:34 blubb Exp $
-inherit eutils wxwidgets python
+inherit eutils wxwidgets python multilib
MY_P="${P/wxpython-/wxPythonSrc-}"
S="${WORKDIR}/${MY_P}/wxPython"
@@ -69,7 +69,7 @@ src_install() {
local mypyconf
local dest
local wx_name
- local site_pkgs=/usr/lib/python${PYVER}/site-packages
+ local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
use opengl \
&& mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
@@ -79,7 +79,8 @@ src_install() {
|| mypyconf="${mypyconf} WXPORT=gtk"
use unicode && mypyconf="${mypyconf} UNICODE=1"
- python setup.py ${mypyconf} install --prefix=/usr --root=${D} || die
+ python setup.py ${mypyconf} install --prefix=/usr \
+ --install-lib=/usr/$(get_libdir)/ --root=${D} || die
# This can all be removed when 2.4.3 is released:
# Future: Make sure we don't clobber existing wxversion.py or wx.pth
@@ -123,7 +124,7 @@ pkg_postinst() {
pkg_postrm() {
python_version
- site_pkgs=/usr/lib/python${PYVER}/site-packages
+ site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
cd ${site_pkgs}
#If 2.4 is removed, set 2.6 as default version:
for wxver in "wx-2.6-gtk2-unicode" "wx-2.6-gtk2-ansi" "wx-2.6-gtk"
diff --git a/dev-python/wxpython/wxpython-2.4.2.4.ebuild b/dev-python/wxpython/wxpython-2.4.2.4.ebuild
index 7602f9e4fca9..a37523cd4366 100644
--- a/dev-python/wxpython/wxpython-2.4.2.4.ebuild
+++ b/dev-python/wxpython/wxpython-2.4.2.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.4.2.4.ebuild,v 1.10 2005/01/26 03:24:40 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.4.2.4.ebuild,v 1.11 2005/09/07 19:16:34 blubb Exp $
-inherit eutils wxwidgets
+inherit eutils wxwidgets multilib
MY_P="${P/wxpython-/wxPythonSrc-}"
S="${WORKDIR}/${MY_P}/wxPython"
@@ -81,5 +81,6 @@ src_install() {
use unicode && mypyconf="${mypyconf} UNICODE=1"
- python setup.py ${mypyconf} install --prefix=/usr --root=${D} || die
+ python setup.py ${mypyconf} install --prefix=/usr \
+ --install-lib=/usr/$(get_libdir)/ --root=${D} || die
}
diff --git a/dev-python/wxpython/wxpython-2.6.0.0-r1.ebuild b/dev-python/wxpython/wxpython-2.6.0.0-r1.ebuild
index 2c358eac8e62..f8a4037fcc16 100644
--- a/dev-python/wxpython/wxpython-2.6.0.0-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.0.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.0.0-r1.ebuild,v 1.1 2005/05/11 20:08:38 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.0.0-r1.ebuild,v 1.2 2005/09/07 19:16:34 blubb Exp $
-inherit python wxwidgets eutils
+inherit python wxwidgets eutils multilib
MY_P="${P/wxpython-/wxPython-src-}"
DESCRIPTION="A blending of the wxWindows C++ class library with Python"
@@ -79,7 +79,7 @@ src_compile() {
src_install() {
python_version
local mypyconf
- local site_pkgs=/usr/lib/python${PYVER}/site-packages
+ local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
dodir ${site_pkgs}
if ! use gtk2; then
diff --git a/dev-python/wxpython/wxpython-2.6.1.0.ebuild b/dev-python/wxpython/wxpython-2.6.1.0.ebuild
index c41f00e590bd..f783d395e249 100644
--- a/dev-python/wxpython/wxpython-2.6.1.0.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.1.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.1.0.ebuild,v 1.1 2005/07/12 18:48:03 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.1.0.ebuild,v 1.2 2005/09/07 19:16:34 blubb Exp $
-inherit python wxwidgets eutils
+inherit python wxwidgets eutils multilib
MY_P="${P/wxpython-/wxPython-src-}"
DESCRIPTION="A blending of the wxWindows C++ class library with Python"
@@ -79,7 +79,7 @@ src_compile() {
src_install() {
python_version
local mypyconf
- local site_pkgs=/usr/lib/python${PYVER}/site-packages
+ local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
dodir ${site_pkgs}
if ! use gtk2; then