summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-10-02 01:32:04 +0000
committerMike Gilbert <floppym@gentoo.org>2012-10-02 01:32:04 +0000
commitc5f71b9ca870184f3e1ec5aac4f29a00ba5f25b9 (patch)
treeba42df07b668f85106a10e6fa1b35d7a0390e5bb /dev-python
parentVersion bump (finally) with a patch to support Ruby 1.8 syntax for a while st... (diff)
downloadgentoo-2-c5f71b9ca870184f3e1ec5aac4f29a00ba5f25b9.tar.gz
gentoo-2-c5f71b9ca870184f3e1ec5aac4f29a00ba5f25b9.tar.bz2
gentoo-2-c5f71b9ca870184f3e1ec5aac4f29a00ba5f25b9.zip
Restrict python 3.3 based on testing by Arfrever.
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygobject/ChangeLog7
-rw-r--r--dev-python/pygobject/pygobject-3.0.4.ebuild6
-rw-r--r--dev-python/pygobject/pygobject-3.2.2.ebuild6
3 files changed, 11 insertions, 8 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index a719e157f763..12a6bfd4ec59 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.166 2012/09/28 05:45:45 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.167 2012/10/02 01:32:04 floppym Exp $
+
+ 02 Oct 2012; Mike Gilbert <floppym@gentoo.org> pygobject-3.0.4.ebuild,
+ pygobject-3.2.2.ebuild:
+ Restrict python 3.3 based on testing by Arfrever.
28 Sep 2012; Matt Turner <mattst88@gentoo.org> pygobject-2.28.6-r52.ebuild,
pygobject-3.2.2.ebuild:
@@ -739,4 +743,3 @@
+pygobject-2.10.1.ebuild:
Add GNOME 2 bindings for Python, needed for system-config-*. Based on 2.11
ebuild in gnome overlay. Gnome herd, feel free to add yourself to metadata.
-
diff --git a/dev-python/pygobject/pygobject-3.0.4.ebuild b/dev-python/pygobject/pygobject-3.0.4.ebuild
index f10d487105cf..2f5a7ab71431 100644
--- a/dev-python/pygobject/pygobject-3.0.4.ebuild
+++ b/dev-python/pygobject/pygobject-3.0.4.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-3.0.4.ebuild,v 1.14 2012/09/25 11:53:14 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-3.0.4.ebuild,v 1.15 2012/10/02 01:32:04 floppym Exp $
EAPI="4"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2:2.6 3:3.1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.0 *-jython 2.7-pypy-*"
+PYTHON_DEPEND="2:2.6 3:3.1:3.2"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.0 3.3 *-jython 2.7-pypy-*"
# XXX: Is the alternatives stuff needed anymore?
inherit alternatives autotools eutils gnome2 python virtualx
diff --git a/dev-python/pygobject/pygobject-3.2.2.ebuild b/dev-python/pygobject/pygobject-3.2.2.ebuild
index 7ff957d342bc..edc29bf2c28d 100644
--- a/dev-python/pygobject/pygobject-3.2.2.ebuild
+++ b/dev-python/pygobject/pygobject-3.2.2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-3.2.2.ebuild,v 1.5 2012/09/28 05:45:45 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-3.2.2.ebuild,v 1.6 2012/10/02 01:32:04 floppym Exp $
EAPI="4"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2:2.6 3:3.1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.0 *-jython *-pypy-*"
+PYTHON_DEPEND="2:2.6 3:3.1:3.2"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.0 3.3 *-jython *-pypy-*"
inherit autotools eutils gnome2 python virtualx