summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-18 20:21:19 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-18 20:21:19 +0000
commitc3eef4f8ef66b457dbb3895c37fcff359650899a (patch)
tree331514060d81a15844fa9bf5c0bbffc5e7b2506f /dev-python
parentUse DISTUTILS_SRC_TEST. (diff)
downloadgentoo-2-c3eef4f8ef66b457dbb3895c37fcff359650899a.tar.gz
gentoo-2-c3eef4f8ef66b457dbb3895c37fcff359650899a.tar.bz2
gentoo-2-c3eef4f8ef66b457dbb3895c37fcff359650899a.zip
Simplify tests.
(Portage version: 2.2.0_alpha9_p3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.ebuild15
1 files changed, 1 insertions, 14 deletions
diff --git a/dev-python/setproctitle/setproctitle-1.1.ebuild b/dev-python/setproctitle/setproctitle-1.1.ebuild
index 3700dec9ba37..00fdcb2d11f5 100644
--- a/dev-python/setproctitle/setproctitle-1.1.ebuild
+++ b/dev-python/setproctitle/setproctitle-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/setproctitle-1.1.ebuild,v 1.1 2010/07/19 00:14:13 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/setproctitle-1.1.ebuild,v 1.2 2010/12/18 20:21:19 arfrever Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
@@ -35,16 +35,3 @@ src_prepare() {
--failure-message 'Applying patches for $(python_get_implementation) $(python_get_version) failed' \
-s conversion
}
-
-src_test() {
- testing() {
- if [[ "${PYTHON_ABI}" == 2.* ]]; then
- echo PYTHONPATH="$(ls -d build/lib.*)" nosetests
- PYTHONPATH="$(ls -d build/lib.*)" nosetests || return 1
- else
- echo PYTHONPATH="$(ls -d build/lib.*)" "$(PYTHON)" tests/setproctitle_test.py
- PYTHONPATH="$(ls -d build/lib.*)" "$(PYTHON)" tests/setproctitle_test.py || return 1
- fi
- }
- python_execute_function -s testing
-}