summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-06 08:32:30 +0000
committerJustin Lecher <jlec@gentoo.org>2015-08-06 08:32:30 +0000
commitc315db78d9dda8d3670158316df5f8f9c28e8b2b (patch)
tree70f5b65dea77d67160756801338e2ccc8c571c0a /dev-python
parentAdd new helpers: 'ghc-pm-version' to get ghc version as seen by package manag... (diff)
downloadgentoo-2-c315db78d9dda8d3670158316df5f8f9c28e8b2b.tar.gz
gentoo-2-c315db78d9dda8d3670158316df5f8f9c28e8b2b.tar.bz2
gentoo-2-c315db78d9dda8d3670158316df5f8f9c28e8b2b.zip
Drop old
Signed-off-by: Justin Lecher <jlec@gentoo.org> (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/click/ChangeLog6
-rw-r--r--dev-python/click/click-2.0.ebuild23
-rw-r--r--dev-python/click/click-3.3.ebuild43
3 files changed, 5 insertions, 67 deletions
diff --git a/dev-python/click/ChangeLog b/dev-python/click/ChangeLog
index 35769e012a06..8a8236eb8050 100644
--- a/dev-python/click/ChangeLog
+++ b/dev-python/click/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/click
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/click/ChangeLog,v 1.16 2015/08/06 07:21:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/click/ChangeLog,v 1.17 2015/08/06 08:32:30 jlec Exp $
+
+ 06 Aug 2015; Justin Lecher <jlec@gentoo.org> -click-2.0.ebuild,
+ -click-3.3.ebuild:
+ Drop old
06 Aug 2015; Agostino Sarubbo <ago@gentoo.org> click-4.0-r1.ebuild:
Stable for x86, wrt bug #556560
diff --git a/dev-python/click/click-2.0.ebuild b/dev-python/click/click-2.0.ebuild
deleted file mode 100644
index df6f186167f2..000000000000
--- a/dev-python/click/click-2.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/click/click-2.0.ebuild,v 1.3 2014/08/06 05:48:12 idella4 Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python package for creating beautiful command line interfaces"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-HOMEPAGE="http://click.pocoo.org/ http://pypi.python.org/pypi/click"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# FIXME: tests docs and examples aren't being shipped with releases.
-# Asked upstream to fix this. Avoided using github snapshots for now. (rafaelmartins)
-IUSE=""
-
-RDEPEND="dev-python/colorama"
-DEPEND="${RDEPEND}"
diff --git a/dev-python/click/click-3.3.ebuild b/dev-python/click/click-3.3.ebuild
deleted file mode 100644
index 260d89d21900..000000000000
--- a/dev-python/click/click-3.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/click/click-3.3.ebuild,v 1.4 2015/06/08 07:14:37 idella4 Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python package for creating beautiful command line interfaces"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-HOMEPAGE="http://click.pocoo.org/ http://pypi.python.org/pypi/click"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-IUSE="doc examples test"
-
-RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- emake test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}