summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-04-24 10:33:34 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-04-24 10:33:34 +0000
commitc1b2df91dacb58c01e3cdaf1d0d10ca5561e58e0 (patch)
tree0d82e6189dc8f1e8ac1af5a78a8cadab8d68a668 /dev-python
parentBump ebuild to -r1 so that we can drop ruby19 and jruby support from 1.5.2 fo... (diff)
downloadgentoo-2-c1b2df91dacb58c01e3cdaf1d0d10ca5561e58e0.tar.gz
gentoo-2-c1b2df91dacb58c01e3cdaf1d0d10ca5561e58e0.tar.bz2
gentoo-2-c1b2df91dacb58c01e3cdaf1d0d10ca5561e58e0.zip
Version bump dev-python/mechanize to 0.2.0.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mechanize/ChangeLog7
-rw-r--r--dev-python/mechanize/mechanize-0.2.0.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/mechanize/ChangeLog b/dev-python/mechanize/ChangeLog
index 54e35be97ab4..bd548e834aee 100644
--- a/dev-python/mechanize/ChangeLog
+++ b/dev-python/mechanize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mechanize
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/ChangeLog,v 1.18 2010/02/14 18:48:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/ChangeLog,v 1.19 2010/04/24 10:33:34 djc Exp $
+
+*mechanize-0.2.0 (24 Apr 2010)
+
+ 24 Apr 2010; Dirkjan Ochtman <djc@gentoo.org> +mechanize-0.2.0.ebuild:
+ Version bump to 0.2.0.
14 Feb 2010; Raúl Porcel <armin76@gentoo.org> mechanize-0.1.11.ebuild:
Add ~alpha/~sparc
diff --git a/dev-python/mechanize/mechanize-0.2.0.ebuild b/dev-python/mechanize/mechanize-0.2.0.ebuild
new file mode 100644
index 000000000000..ec12cb9fc6a5
--- /dev/null
+++ b/dev-python/mechanize/mechanize-0.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/mechanize-0.2.0.ebuild,v 1.1 2010/04/24 10:33:34 djc Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="Stateful programmatic web browsing in Python"
+HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/ http://pypi.python.org/pypi/mechanize"
+SRC_URI="http://wwwsearch.sourceforge.net/${PN}/src/${P}.tar.gz"
+
+LICENSE="|| ( BSD ZPL )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS="0.1-changes.txt"
+
+src_prepare() {
+ # Use distutils instead of setuptools.
+ # (This can't be removed in the same ${PV} due to file->directory replacement.)
+ sed -e 's/not hasattr(sys, "version_info")/True/' -i setup.py || die "sed in setup.py failed"
+
+ # We don't run coverage tests or functional_tests
+ # which access the network, just doctests and unit tests
+ sed -e '/import coverage/d' -i test.py || die "sed in test.py failed"
+}
+
+src_test() {
+ testing() {
+ # ignore warnings http://github.com/jjlee/mechanize/issues/issue/13
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" -Wignore test.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ # Remove some files to prevent distutils_src_install from installing them.
+ dohtml *.html
+ rm -f README.html*
+
+ distutils_src_install
+}