summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-11-24 21:34:53 +0000
committerTim Harder <radhermit@gentoo.org>2013-11-24 21:34:53 +0000
commitb935ddb45b0b900e87b2134df29a07a5dd2cf361 (patch)
tree05c78b376d8d61190665e0eee32dc6cbef606c7d /dev-python
parentdisable SRC_TEST wrt bug #492212 (diff)
downloadgentoo-2-b935ddb45b0b900e87b2134df29a07a5dd2cf361.tar.gz
gentoo-2-b935ddb45b0b900e87b2134df29a07a5dd2cf361.tar.bz2
gentoo-2-b935ddb45b0b900e87b2134df29a07a5dd2cf361.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto/ChangeLog7
-rw-r--r--dev-python/boto/boto-2.18.0.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index f4d8c33e9fbd..a07457f69648 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.79 2013/11/24 18:41:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.80 2013/11/24 21:34:53 radhermit Exp $
+
+*boto-2.18.0 (24 Nov 2013)
+
+ 24 Nov 2013; Tim Harder <radhermit@gentoo.org> +boto-2.18.0.ebuild:
+ Version bump.
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> boto-2.11.0.ebuild:
Stable for ppc, wrt bug #486280
diff --git a/dev-python/boto/boto-2.18.0.ebuild b/dev-python/boto/boto-2.18.0.ebuild
new file mode 100644
index 000000000000..8b1b8e897e6f
--- /dev/null
+++ b/dev-python/boto/boto-2.18.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.18.0.ebuild,v 1.1 2013/11/24 21:34:53 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}