summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-08-07 00:20:27 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-08-07 00:20:27 +0000
commitb7849c3f9d5592ef1b4590fab55748de7183b513 (patch)
tree6e5f38a191cf3e8c5fac02f9cafd6f32f7438b9f /dev-python
parentRemove java-virtuals/javamail dependency and replace it with oracle-javamail.... (diff)
downloadgentoo-2-b7849c3f9d5592ef1b4590fab55748de7183b513.tar.gz
gentoo-2-b7849c3f9d5592ef1b4590fab55748de7183b513.tar.bz2
gentoo-2-b7849c3f9d5592ef1b4590fab55748de7183b513.zip
Readd removed version.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/click/ChangeLog7
-rw-r--r--dev-python/click/click-2.0.ebuild23
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-python/click/ChangeLog b/dev-python/click/ChangeLog
index 8a8236eb8050..0878b9406392 100644
--- a/dev-python/click/ChangeLog
+++ b/dev-python/click/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/click
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/click/ChangeLog,v 1.17 2015/08/06 08:32:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/click/ChangeLog,v 1.18 2015/08/07 00:20:27 mrueg Exp $
+
+*click-2.0 (07 Aug 2015)
+
+ 07 Aug 2015; Manuel Rüger <mrueg@gentoo.org> +click-2.0.ebuild:
+ Readd removed version.
06 Aug 2015; Justin Lecher <jlec@gentoo.org> -click-2.0.ebuild,
-click-3.3.ebuild:
diff --git a/dev-python/click/click-2.0.ebuild b/dev-python/click/click-2.0.ebuild
new file mode 100644
index 000000000000..3eb4d15e59e8
--- /dev/null
+++ b/dev-python/click/click-2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/click/click-2.0.ebuild,v 1.5 2015/08/07 00:20:27 mrueg Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ http://pypi.python.org/pypi/click"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# FIXME: tests docs and examples aren't being shipped with releases.
+# Asked upstream to fix this. Avoided using github snapshots for now. (rafaelmartins)
+IUSE=""
+
+RDEPEND="dev-python/colorama"
+DEPEND="${RDEPEND}"