summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-09-25 12:12:19 +0000
committerAli Polatel <hawking@gentoo.org>2008-09-25 12:12:19 +0000
commitb6b469d702993e568deb425ad0db4ade66a4b2f9 (patch)
tree3a753eb6e7c78fb6639b095c87d047fafa3e09b2 /dev-python
parentkeyword ~x86-fbsd (diff)
downloadgentoo-2-b6b469d702993e568deb425ad0db4ade66a4b2f9.tar.gz
gentoo-2-b6b469d702993e568deb425ad0db4ade66a4b2f9.tar.bz2
gentoo-2-b6b469d702993e568deb425ad0db4ade66a4b2f9.zip
Version bump.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mechanize/ChangeLog9
-rw-r--r--dev-python/mechanize/mechanize-0.1.9.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-python/mechanize/ChangeLog b/dev-python/mechanize/ChangeLog
index 5650645a7bfe..816e861eb346 100644
--- a/dev-python/mechanize/ChangeLog
+++ b/dev-python/mechanize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mechanize
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/ChangeLog,v 1.5 2007/07/01 13:20:05 pylon Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/ChangeLog,v 1.6 2008/09/25 12:12:19 hawking Exp $
+
+*mechanize-0.1.9 (24 Sep 2008)
+
+ 24 Sep 2008; Ali Polatel <hawking@gentoo.org> +mechanize-0.1.9.ebuild:
+ Version bump.
01 Jul 2007; Lars Weiler <pylon@gentoo.org> mechanize-0.1.7b.ebuild:
Keyworded ~ppc; bug #166914.
diff --git a/dev-python/mechanize/mechanize-0.1.9.ebuild b/dev-python/mechanize/mechanize-0.1.9.ebuild
new file mode 100644
index 000000000000..c977b9cb046f
--- /dev/null
+++ b/dev-python/mechanize/mechanize-0.1.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/mechanize-0.1.9.ebuild,v 1.1 2008/09/25 12:12:19 hawking Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils
+
+DESCRIPTION="Stateful programmatic web browsing in Python"
+HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/"
+SRC_URI="http://wwwsearch.sourceforge.net/${PN}/src/${P}.tar.gz"
+
+LICENSE="|| ( BSD ZPL )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/clientform-0.2.7"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # use distutils instead of setuptools
+ sed -i \
+ -e 's/not hasattr(sys, "version_info")/1/' \
+ setup.py || die "sed in setup.py failed"
+
+ # We don't run coverage tests or functional_tests
+ # which access the network, just doctests and unit tests
+ sed -i \
+ -e '/import coverage/d' \
+ test.py || die "sed in test.py failed"
+}
+
+src_install() {
+ DOCS="0.1-changes.txt"
+ # remove to prevent distutils_src_install from installing it
+ dohtml *.html
+ rm README.html*
+
+ distutils_src_install
+}
+
+src_test() {
+ PYTHONPATH=build/lib/ "${python}" test.py || die "tests failed"
+}