summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-19 18:59:19 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-19 18:59:19 +0000
commitb1925556a07752d0093274b163cbcd8753136298 (patch)
treec96f629228a7c02509807223ba6ff4f7403b8129 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-b1925556a07752d0093274b163cbcd8753136298.tar.gz
gentoo-2-b1925556a07752d0093274b163cbcd8753136298.tar.bz2
gentoo-2-b1925556a07752d0093274b163cbcd8753136298.zip
Version bump.
(Portage version: 15121-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/ChangeLog8
-rw-r--r--dev-python/pylint/pylint-0.19.0.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index 1060e5ce2000..80f8afabd28c 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.56 2009/12/05 11:44:07 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.57 2009/12/19 18:59:19 arfrever Exp $
+
+*pylint-0.19.0 (19 Dec 2009)
+
+ 19 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pylint-0.19.0.ebuild:
+ Version bump.
05 Dec 2009; Christian Ruppert <idl0r@gentoo.org> pylint-0.18.1-r1.ebuild:
Fix dependency, bug 295750.
diff --git a/dev-python/pylint/pylint-0.19.0.ebuild b/dev-python/pylint/pylint-0.19.0.ebuild
new file mode 100644
index 000000000000..b892ed7a61af
--- /dev/null
+++ b/dev-python/pylint/pylint-0.19.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.19.0.ebuild,v 1.1 2009/12/19 18:59:19 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="a tool to check if a Python module satisfies a coding standard"
+HOMEPAGE="http://www.logilab.org/projects/pylint/ http://pypi.python.org/pypi/pylint"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc examples test tk"
+
+DEPEND=">=dev-python/logilab-common-0.44.0
+ >=dev-python/astng-0.19.0"
+RDEPEND="${DEPEND}
+ dev-lang/python[tk?]"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable failing tests.
+ rm -f test/input/func_arguments.py
+ sed -e "s/test_exhaustivity/_&/" -i test/test_func.py || die "sed failed"
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" pytest -v
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ doman man/{pylint,pyreverse}.1 || die "doman failed"
+ dodoc doc/FAQ.txt || die "dodoc failed"
+
+ if use doc; then
+ dodoc doc/*.txt || die "dodoc failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc failed"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ if ! has_version dev-lang/python[tk]; then
+ ewarn "dev-lang/python has been built without tk support,"
+ ewarn "${PN}-gui doesn't work without Tkinter so if you really need it,"
+ ewarn "re-install dev-lang/python with \"tk\" useflag enabled."
+ fi
+}