summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-29 06:33:16 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-29 06:33:16 +0000
commitaf02e4a3950c60449368e1207faff00c2ab479bc (patch)
treed1fd065a7e5e52230d16bae6146c692aed8c29b8 /dev-python
parentBump (diff)
downloadgentoo-2-af02e4a3950c60449368e1207faff00c2ab479bc.tar.gz
gentoo-2-af02e4a3950c60449368e1207faff00c2ab479bc.tar.bz2
gentoo-2-af02e4a3950c60449368e1207faff00c2ab479bc.zip
Bump
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/simplejson/ChangeLog7
-rw-r--r--dev-python/simplejson/simplejson-2.6.1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index 337e515f8bcd..6a744243ca4e 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.68 2012/06/28 07:36:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.69 2012/08/29 06:33:16 patrick Exp $
+
+*simplejson-2.6.1 (29 Aug 2012)
+
+ 29 Aug 2012; Patrick Lauer <patrick@gentoo.org> +simplejson-2.6.1.ebuild:
+ Bump
*simplejson-2.6.0 (28 Jun 2012)
diff --git a/dev-python/simplejson/simplejson-2.6.1.ebuild b/dev-python/simplejson/simplejson-2.6.1.ebuild
new file mode 100644
index 000000000000..3195f7b05b41
--- /dev/null
+++ b/dev-python/simplejson/simplejson-2.6.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-2.6.1.ebuild,v 1.1 2012/08/29 06:33:16 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_test() {
+ testing() {
+ if [[ "$(python_get_implementation)" != "Jython" ]]; then
+ ln -fs ../$(ls -d build-${PYTHON_ABI}/lib*)/simplejson/_speedups.so simplejson/_speedups.so || return 1
+ fi
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" simplejson/tests/__init__.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/simplejson/tests"
+ }
+ python_execute_function -q delete_tests
+}