summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-06-15 21:48:46 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-06-15 21:48:46 +0000
commitacbe5a3e70a70e7cc6c811473c4a3bf253ef77ad (patch)
tree856098a9cce26ae3cd9425151b3395d5be698906 /dev-python
parentVersion bump. Remove old. (diff)
downloadgentoo-2-acbe5a3e70a70e7cc6c811473c4a3bf253ef77ad.tar.gz
gentoo-2-acbe5a3e70a70e7cc6c811473c4a3bf253ef77ad.tar.bz2
gentoo-2-acbe5a3e70a70e7cc6c811473c4a3bf253ef77ad.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jsonpointer/ChangeLog7
-rw-r--r--dev-python/jsonpointer/jsonpointer-1.9.ebuild23
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-python/jsonpointer/ChangeLog b/dev-python/jsonpointer/ChangeLog
index a81e8ef6bd0f..c40a3f56b95f 100644
--- a/dev-python/jsonpointer/ChangeLog
+++ b/dev-python/jsonpointer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/jsonpointer
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpointer/ChangeLog,v 1.11 2015/06/07 13:40:42 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpointer/ChangeLog,v 1.12 2015/06/15 21:48:46 mrueg Exp $
+
+*jsonpointer-1.9 (15 Jun 2015)
+
+ 15 Jun 2015; Manuel Rüger <mrueg@gentoo.org> +jsonpointer-1.9.ebuild:
+ Version bump.
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-python/jsonpointer/jsonpointer-1.9.ebuild b/dev-python/jsonpointer/jsonpointer-1.9.ebuild
new file mode 100644
index 000000000000..200346837cab
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-1.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpointer/jsonpointer-1.9.ebuild,v 1.1 2015/06/15 21:48:46 mrueg Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.python.org/pypi/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}