summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-03-23 05:28:21 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-03-23 05:28:21 +0000
commita790214fe1f1f03356d5fc32f6399f4d1034e6d0 (patch)
tree9e5a52caa57f7d217f97d58bc8b0ef1f17c3bbec /dev-python
parentRe-add version needed by net-libs/hubbub (diff)
downloadgentoo-2-a790214fe1f1f03356d5fc32f6399f4d1034e6d0.tar.gz
gentoo-2-a790214fe1f1f03356d5fc32f6399f4d1034e6d0.tar.bz2
gentoo-2-a790214fe1f1f03356d5fc32f6399f4d1034e6d0.zip
Readd 0.25 as dependency of dev-python/oslo-vmware
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/ChangeLog7
-rw-r--r--dev-python/pylint/pylint-0.25.2.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index 63bfec7740b2..667c929fad7c 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.122 2015/03/22 08:12:18 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.123 2015/03/23 05:28:21 patrick Exp $
+
+*pylint-0.25.2 (23 Mar 2015)
+
+ 23 Mar 2015; Patrick Lauer <patrick@gentoo.org> +pylint-0.25.2.ebuild:
+ Readd 0.25 as dependency of dev-python/oslo-vmware
22 Mar 2015; Patrick Lauer <patrick@gentoo.org> -pylint-0.23.0.ebuild,
-pylint-0.25.2.ebuild, pylint-1.4.3.ebuild:
diff --git a/dev-python/pylint/pylint-0.25.2.ebuild b/dev-python/pylint/pylint-0.25.2.ebuild
new file mode 100644
index 000000000000..2b8605b25ee1
--- /dev/null
+++ b/dev-python/pylint/pylint-0.25.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.25.2.ebuild,v 1.6 2015/03/23 05:28:21 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="http://www.logilab.org/project/pylint http://pypi.python.org/pypi/pylint"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="examples"
+
+# Versions specified in __pkginfo__.py.
+RDEPEND=">=dev-python/logilab-common-0.53.0[${PYTHON_USEDEP}]
+ >=dev-python/astng-0.24.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}"/${PN}-0.26.0-gtktest.patch )
+
+python_test() {
+ # Test suite broken with Python 3
+ local msg="Test suite broken with ${EPYTHON}"
+ if [[ "${EPYTHON}" == python3* ]]; then
+ einfo "${msg}"
+ else
+ # https://bitbucket.org/logilab/pylint/issue/11/apparent-regression-in-testsuite-pylint
+ # This 'issue' became' declared fixed by accident for version 0.27.0 despite being made citing 0.28.0
+ pytest || die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/{pylint,pyreverse}.1
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*
+ fi
+}
+
+pkg_postinst() {
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ elog "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled."
+}