summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-06-18 23:25:49 +0000
committerMike Gilbert <floppym@gentoo.org>2013-06-18 23:25:49 +0000
commita77a08656770f24cc2d130e1c969b0e97f29c485 (patch)
tree60fc8d649e3b9e46cbfed7355672734429a772bf /dev-python
parentremove old (diff)
downloadgentoo-2-a77a08656770f24cc2d130e1c969b0e97f29c485.tar.gz
gentoo-2-a77a08656770f24cc2d130e1c969b0e97f29c485.tar.bz2
gentoo-2-a77a08656770f24cc2d130e1c969b0e97f29c485.zip
Version bump. Restore DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT variable.
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/setuptools/ChangeLog9
-rw-r--r--dev-python/setuptools/setuptools-0.7.2-r1.ebuild7
-rw-r--r--dev-python/setuptools/setuptools-0.7.3.ebuild44
3 files changed, 58 insertions, 2 deletions
diff --git a/dev-python/setuptools/ChangeLog b/dev-python/setuptools/ChangeLog
index 78c45f9a5b6c..f4a7c8de5202 100644
--- a/dev-python/setuptools/ChangeLog
+++ b/dev-python/setuptools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/setuptools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.189 2013/06/15 00:44:05 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.190 2013/06/18 23:25:49 floppym Exp $
+
+*setuptools-0.7.3 (18 Jun 2013)
+
+ 18 Jun 2013; Mike Gilbert <floppym@gentoo.org> +setuptools-0.7.3.ebuild,
+ setuptools-0.7.2-r1.ebuild:
+ Version bump. Restore DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT
+ variable.
*setuptools-0.7.2-r1 (15 Jun 2013)
diff --git a/dev-python/setuptools/setuptools-0.7.2-r1.ebuild b/dev-python/setuptools/setuptools-0.7.2-r1.ebuild
index 0ad6f128aa00..02d5d4994672 100644
--- a/dev-python/setuptools/setuptools-0.7.2-r1.ebuild
+++ b/dev-python/setuptools/setuptools-0.7.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.7.2-r1.ebuild,v 1.1 2013/06/15 00:44:05 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.7.2-r1.ebuild,v 1.2 2013/06/18 23:25:49 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
@@ -41,3 +41,8 @@ python_prepare_all() {
python_test() {
esetup.py test
}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}
diff --git a/dev-python/setuptools/setuptools-0.7.3.ebuild b/dev-python/setuptools/setuptools-0.7.3.ebuild
new file mode 100644
index 000000000000..5f5544caca25
--- /dev/null
+++ b/dev-python/setuptools/setuptools-0.7.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.7.3.ebuild,v 1.1 2013/06/18 23:25:49 floppym Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="a collection of extensions to Distutils"
+HOMEPAGE="http://pypi.python.org/pypi/setuptools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare() {
+ if [[ "${EPYTHON}" == 'python2.5' ]]; then
+ epatch "${FILESDIR}"/${PN}-0.7.2-test-easy.patch
+ fi
+}
+
+python_prepare_all() {
+ # Disable tests requiring network connection.
+ rm -f setuptools/tests/test_packageindex.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}