summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-02 15:43:09 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-02 15:43:09 +0000
commita4bf3ea4cce2d3475d65995eb93d578cea7ad2f9 (patch)
tree807e2dae119dc00bd42d1832853c155f52054ce0 /dev-python
parentMarking courier-imap-4.5.0 ppc64 for bug 287933 (diff)
downloadgentoo-2-a4bf3ea4cce2d3475d65995eb93d578cea7ad2f9.tar.gz
gentoo-2-a4bf3ea4cce2d3475d65995eb93d578cea7ad2f9.tar.bz2
gentoo-2-a4bf3ea4cce2d3475d65995eb93d578cea7ad2f9.zip
Adding RESTRICT_PYTHON_ABIS for python3. Current PyQt4 versions only work with python2. Fixes bug 292419.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt4/ChangeLog9
-rw-r--r--dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild5
-rw-r--r--dev-python/PyQt4/PyQt4-4.6.2.ebuild5
3 files changed, 13 insertions, 6 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 1d58b91bb429..3d560b8edc8f 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt4
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.98 2009/12/13 15:49:01 yngwin Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.99 2010/01/02 15:43:09 yngwin Exp $
+
+ 02 Jan 2010; Ben de Groot <yngwin@gentoo.org> PyQt4-4.5.4-r4.ebuild,
+ PyQt4-4.6.2.ebuild:
+ Adding RESTRICT_PYTHON_ABIS for python3. Current PyQt4 versions only work
+ with python2. Fixes bug 292419.
13 Dec 2009; Ben de Groot <yngwin@gentoo.org> -PyQt4-4.4.4-r2.ebuild,
-PyQt4-4.4.4-r5.ebuild, -PyQt4-4.5.2.ebuild, -PyQt4-4.5.4-r3.ebuild,
diff --git a/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild b/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild
index 0464a0414ded..8dc77ac80200 100644
--- a/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild,v 1.9 2009/12/13 15:49:01 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.4-r4.ebuild,v 1.10 2010/01/02 15:43:09 yngwin Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit python qt4 toolchain-funcs
diff --git a/dev-python/PyQt4/PyQt4-4.6.2.ebuild b/dev-python/PyQt4/PyQt4-4.6.2.ebuild
index a7d8410f26d0..733754ba35ea 100644
--- a/dev-python/PyQt4/PyQt4-4.6.2.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.6.2.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.6.2.ebuild,v 1.2 2009/12/13 15:49:01 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.6.2.ebuild,v 1.3 2010/01/02 15:43:09 yngwin Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit python qt4 toolchain-funcs