summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2014-12-21 04:53:17 +0000
committerAlex Brandt <alunduil@gentoo.org>2014-12-21 04:53:17 +0000
commit9ed780d98f0eed8ed80eed83662959245ef4b890 (patch)
tree47128147600daeb1e98352414f88748b0ab70cba /dev-python
parentremove live ebuild (diff)
downloadgentoo-2-9ed780d98f0eed8ed80eed83662959245ef4b890.tar.gz
gentoo-2-9ed780d98f0eed8ed80eed83662959245ef4b890.tar.bz2
gentoo-2-9ed780d98f0eed8ed80eed83662959245ef4b890.zip
add version 1.3.0
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/oslotest/ChangeLog7
-rw-r--r--dev-python/oslotest/oslotest-1.3.0.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/dev-python/oslotest/ChangeLog b/dev-python/oslotest/ChangeLog
index f692c7c28b17..fd09e9eaa796 100644
--- a/dev-python/oslotest/ChangeLog
+++ b/dev-python/oslotest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/oslotest
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/ChangeLog,v 1.6 2014/11/25 09:44:12 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/ChangeLog,v 1.7 2014/12/21 04:53:17 alunduil Exp $
+
+*oslotest-1.3.0 (21 Dec 2014)
+
+ 21 Dec 2014; Alex Brandt <alunduil@gentoo.org> +oslotest-1.3.0.ebuild:
+ add version 1.3.0
25 Nov 2014; Pacho Ramos <pacho@gentoo.org> oslotest-1.1.0.ebuild:
Support python 3.4
diff --git a/dev-python/oslotest/oslotest-1.3.0.ebuild b/dev-python/oslotest/oslotest-1.3.0.ebuild
new file mode 100644
index 000000000000..2feb6d6f1361
--- /dev/null
+++ b/dev-python/oslotest/oslotest-1.3.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/oslotest-1.3.0.ebuild,v 1.1 2014/12/21 04:53:17 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack test framework"
+HOMEPAGE="http://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~x86 ~x86-linux"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ !~dev-python/pbr-0.7[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ <dev-python/hacking-0.10[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.9.2[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ !~dev-python/testtools-1.2.0[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ local DISTUTILS_NO_PARALLEL_BUILD=TRUE
+
+ rm -rf .testrepository || die "coudln't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ use doc && doman doc/build/man/oslotest.1
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "man page installation requires USE=doc"
+}