summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2012-06-24 15:13:58 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2012-06-24 15:13:58 +0000
commit9e59404e23f120eb29e836f234ac2a0ad1378712 (patch)
tree2a371a707802444c147416078d856c72f3565fb9 /dev-python
parentStore version information in system-configuration-options variable. (diff)
downloadgentoo-2-9e59404e23f120eb29e836f234ac2a0ad1378712.tar.gz
gentoo-2-9e59404e23f120eb29e836f234ac2a0ad1378712.tar.bz2
gentoo-2-9e59404e23f120eb29e836f234ac2a0ad1378712.zip
Fix tests. Closes #423101
(Portage version: 2.2.0_alpha111/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cliapp/ChangeLog5
-rw-r--r--dev-python/cliapp/cliapp-0.29.ebuild11
2 files changed, 14 insertions, 2 deletions
diff --git a/dev-python/cliapp/ChangeLog b/dev-python/cliapp/ChangeLog
index 501b880e2869..43bd2f83594a 100644
--- a/dev-python/cliapp/ChangeLog
+++ b/dev-python/cliapp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/cliapp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cliapp/ChangeLog,v 1.1 2012/06/15 10:16:15 mschiff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cliapp/ChangeLog,v 1.2 2012/06/24 15:13:58 mschiff Exp $
+
+ 24 Jun 2012; Marc Schiffbauer <mschiff@gentoo.org> cliapp-0.29.ebuild:
+ Fix tests. Closes #423101
*cliapp-0.29 (15 Jun 2012)
diff --git a/dev-python/cliapp/cliapp-0.29.ebuild b/dev-python/cliapp/cliapp-0.29.ebuild
index f1f111b294db..5b0be0277759 100644
--- a/dev-python/cliapp/cliapp-0.29.ebuild
+++ b/dev-python/cliapp/cliapp-0.29.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cliapp/cliapp-0.29.ebuild,v 1.1 2012/06/15 10:16:15 mschiff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cliapp/cliapp-0.29.ebuild,v 1.2 2012/06/24 15:13:58 mschiff Exp $
EAPI=4
@@ -17,7 +17,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+DEPEND="test? ( dev-python/CoverageTestRunner )"
+
pkg_setup() {
python_set_active_version 2
python_pkg_setup
}
+
+src_test() {
+ # remove build directory so tests will not fail
+ # due to tests defined twice
+ rm -rf "${S}"/build
+ default
+}