summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-10-29 17:58:32 +0000
committerMichał Górny <mgorny@gentoo.org>2013-10-29 17:58:32 +0000
commit99bbeb8bd2507a446b4221a653aecdc0a68ba252 (patch)
treecff9303e58ddd28da9206d60fcc4092e02602cd8 /dev-python
parentCleanup for security bug #474354 (diff)
downloadgentoo-2-99bbeb8bd2507a446b4221a653aecdc0a68ba252.tar.gz
gentoo-2-99bbeb8bd2507a446b4221a653aecdc0a68ba252.tar.bz2
gentoo-2-99bbeb8bd2507a446b4221a653aecdc0a68ba252.zip
Add a temporarily PDEP hack to avoid breaking systems by removing python-exec:0. Restore old ebuild names to make it possible to propagate it through dynamic-deps.
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-exec/ChangeLog12
-rw-r--r--dev-python/python-exec/python-exec-2.0-r1.ebuild69
-rw-r--r--dev-python/python-exec/python-exec-2.0-r2.ebuild5
-rw-r--r--dev-python/python-exec/python-exec-2.0-r3.ebuild69
-rw-r--r--dev-python/python-exec/python-exec-2.9999.ebuild5
5 files changed, 157 insertions, 3 deletions
diff --git a/dev-python/python-exec/ChangeLog b/dev-python/python-exec/ChangeLog
index f79b8647cc3b..d8c37198344b 100644
--- a/dev-python/python-exec/ChangeLog
+++ b/dev-python/python-exec/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-python/python-exec
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/ChangeLog,v 1.58 2013/10/26 16:35:52 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/ChangeLog,v 1.59 2013/10/29 17:58:32 mgorny Exp $
+
+*python-exec-2.0-r3 (29 Oct 2013)
+*python-exec-2.0-r1 (29 Oct 2013)
+
+ 29 Oct 2013; Michał Górny <mgorny@gentoo.org> +python-exec-2.0-r1.ebuild,
+ +python-exec-2.0-r3.ebuild, python-exec-2.0-r2.ebuild,
+ python-exec-2.9999.ebuild:
+ Add a temporarily PDEP hack to avoid breaking systems by removing python-
+ exec:0. Restore old ebuild names to make it possible to propagate it through
+ dynamic-deps.
*python-exec-2.0-r2 (26 Oct 2013)
diff --git a/dev-python/python-exec/python-exec-2.0-r1.ebuild b/dev-python/python-exec/python-exec-2.0-r1.ebuild
new file mode 100644
index 000000000000..10104d6e8394
--- /dev/null
+++ b/dev-python/python-exec/python-exec-2.0-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/python-exec-2.0-r1.ebuild,v 1.6 2013/10/29 17:58:32 mgorny Exp $
+
+EAPI=5
+
+# Kids, don't do this at home!
+inherit python-utils-r1
+PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
+
+inherit autotools-utils python-r1 versionator
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Temporarily fail-safe to avoid breaking systems.
+PDEPEND="dev-python/python-exec:0"
+
+src_configure() {
+ local pyimpls i EPYTHON
+ for i in "${PYTHON_COMPAT[@]}"; do
+ python_export "${i}" EPYTHON
+ pyimpls+=" ${EPYTHON}"
+ done
+
+ local myeconfargs=(
+ --with-eprefix="${EPREFIX}"
+ --with-python-impls="${pyimpls}"
+ )
+
+ autotools-utils_src_configure
+}
+
+cleanup_vardb_deps() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ # if 2.0-r1+ was installed already, no need for cleaning up again.
+ if version_is_at_least 2.0-r2 ${v}; then
+ return 0
+ fi
+ done
+
+ local f files=()
+ for f in "${EROOT%/}"/var/db/pkg/*/*/*DEPEND; do
+ if grep -q 'dev-python/python-exec\[' "${f}"; then
+ files+=( "${f}" )
+ fi
+ done
+
+ if [[ ${files[@]} ]]; then
+ ebegin "Fixing unslotted python-exec dependencies in installed packages"
+ sed -i -e 's,dev-python/python-exec\[,dev-python/python-exec:0[,g' \
+ "${files[@]}"
+ eend ${?}
+
+ # touch packages, categories and vardb. suggested by Arfrever.
+ touch "${files[@]%/*}" "${files[@]%/*/*}" "${EROOT%/}"/var/db/pkg
+ fi
+}
+
+pkg_postinst() {
+ cleanup_vardb_deps
+}
diff --git a/dev-python/python-exec/python-exec-2.0-r2.ebuild b/dev-python/python-exec/python-exec-2.0-r2.ebuild
index 871fc5d40e0d..22752939c6bb 100644
--- a/dev-python/python-exec/python-exec-2.0-r2.ebuild
+++ b/dev-python/python-exec/python-exec-2.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/python-exec-2.0-r2.ebuild,v 1.1 2013/10/26 16:35:52 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/python-exec-2.0-r2.ebuild,v 1.2 2013/10/29 17:58:32 mgorny Exp $
EAPI=5
@@ -19,6 +19,9 @@ SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
+# Temporarily fail-safe to avoid breaking systems.
+PDEPEND="dev-python/python-exec:0"
+
src_configure() {
local pyimpls i EPYTHON
for i in "${PYTHON_COMPAT[@]}"; do
diff --git a/dev-python/python-exec/python-exec-2.0-r3.ebuild b/dev-python/python-exec/python-exec-2.0-r3.ebuild
new file mode 100644
index 000000000000..72835f5e2cf7
--- /dev/null
+++ b/dev-python/python-exec/python-exec-2.0-r3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/python-exec-2.0-r3.ebuild,v 1.1 2013/10/29 17:58:32 mgorny Exp $
+
+EAPI=5
+
+# Kids, don't do this at home!
+inherit python-utils-r1
+PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
+
+inherit autotools-utils python-r1 versionator
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Temporarily fail-safe to avoid breaking systems.
+PDEPEND="dev-python/python-exec:0"
+
+src_configure() {
+ local pyimpls i EPYTHON
+ for i in "${PYTHON_COMPAT[@]}"; do
+ python_export "${i}" EPYTHON
+ pyimpls+=" ${EPYTHON}"
+ done
+
+ local myeconfargs=(
+ --with-eprefix="${EPREFIX}"
+ --with-python-impls="${pyimpls}"
+ )
+
+ autotools-utils_src_configure
+}
+
+cleanup_vardb_deps() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ # if 2.0-r1+ was installed already, no need for cleaning up again.
+ if version_is_at_least 2.0-r2 ${v}; then
+ return 0
+ fi
+ done
+
+ local f files=()
+ for f in "${EROOT%/}"/var/db/pkg/*/*/*DEPEND; do
+ if grep -q 'dev-python/python-exec\[' "${f}"; then
+ files+=( "${f}" )
+ fi
+ done
+
+ if [[ ${files[@]} ]]; then
+ ebegin "Fixing unslotted python-exec dependencies in installed packages"
+ sed -i -e 's,dev-python/python-exec\[,dev-python/python-exec:0[,g' \
+ "${files[@]}"
+ eend ${?}
+
+ # touch packages, categories and vardb. suggested by Arfrever.
+ touch "${files[@]%/*}" "${files[@]%/*/*}" "${EROOT%/}"/var/db/pkg
+ fi
+}
+
+pkg_postinst() {
+ cleanup_vardb_deps
+}
diff --git a/dev-python/python-exec/python-exec-2.9999.ebuild b/dev-python/python-exec/python-exec-2.9999.ebuild
index 979ff3ba2d8f..998fe76336e2 100644
--- a/dev-python/python-exec/python-exec-2.9999.ebuild
+++ b/dev-python/python-exec/python-exec-2.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/python-exec-2.9999.ebuild,v 1.6 2013/10/26 16:35:52 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/python-exec-2.9999.ebuild,v 1.7 2013/10/29 17:58:32 mgorny Exp $
EAPI=5
@@ -27,6 +27,9 @@ SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
+# Temporarily fail-safe to avoid breaking systems.
+PDEPEND="dev-python/python-exec:0"
+
#if LIVE
KEYWORDS=
SRC_URI=