summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2010-06-16 18:53:16 +0000
committerDominik Kapusta <ayoy@gentoo.org>2010-06-16 18:53:16 +0000
commit9923c29e9e10a2055fc1942134dd2d6a1358b54c (patch)
tree98eaf3ca00b484430dfd9a988ac4ce890d695eca /dev-python
parentBug #323871: Ensure CHK files are valid more often, and prevent them from bei... (diff)
downloadgentoo-2-9923c29e9e10a2055fc1942134dd2d6a1358b54c.tar.gz
gentoo-2-9923c29e9e10a2055fc1942134dd2d6a1358b54c.tar.bz2
gentoo-2-9923c29e9e10a2055fc1942134dd2d6a1358b54c.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/apiextractor/ChangeLog7
-rw-r--r--dev-python/apiextractor/apiextractor-0.6.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/apiextractor/ChangeLog b/dev-python/apiextractor/ChangeLog
index 90b173a6bc74..6fae8b05ff52 100644
--- a/dev-python/apiextractor/ChangeLog
+++ b/dev-python/apiextractor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/apiextractor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/ChangeLog,v 1.4 2010/01/20 23:38:16 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/ChangeLog,v 1.5 2010/06/16 18:53:16 ayoy Exp $
+
+*apiextractor-0.6.0 (16 Jun 2010)
+
+ 16 Jun 2010; Dominik Kapusta <ayoy@gentoo.org> +apiextractor-0.6.0.ebuild:
+ Version bump
*apiextractor-0.3.3 (20 Jan 2010)
diff --git a/dev-python/apiextractor/apiextractor-0.6.0.ebuild b/dev-python/apiextractor/apiextractor-0.6.0.ebuild
new file mode 100644
index 000000000000..e47571129f7e
--- /dev/null
+++ b/dev-python/apiextractor/apiextractor-0.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/apiextractor-0.6.0.ebuild,v 1.1 2010/06/16 18:53:16 ayoy Exp $
+
+EAPI="2"
+
+inherit cmake-utils virtualx
+
+DESCRIPTION="Library used to create an internal representation of an API in order to create Python bindings"
+HOMEPAGE="http://www.pyside.org/"
+SRC_URI="http://www.pyside.org/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/boost-1.41.0[python]
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=x11-libs/qt-core-4.5.0
+ >=x11-libs/qt-xmlpatterns-4.5.0"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -e 's:cmake-${CMAKE_MAJOR_VERSION}\.${CMAKE_MINOR_VERSION}:cmake:' \
+ -e '/^install/s/lib/lib${LIB_SUFFIX}/' \
+ -i CMakeLists.txt || die "sed failed"
+}
+
+src_test() {
+ # bug 299766
+ Xemake test -C "${CMAKE_BUILD_DIR}/tests" || die "running tests failed"
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS ChangeLog || die "dodoc failed"
+}