summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-05-24 14:46:37 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-05-24 14:46:37 +0000
commit98bd018cd51e772002f2943ea15bd443773b6368 (patch)
treefeff36df3741b3f05a948c4d7d8d3c1813072f0f /dev-python
parentversion bump (diff)
downloadgentoo-2-98bd018cd51e772002f2943ea15bd443773b6368.tar.gz
gentoo-2-98bd018cd51e772002f2943ea15bd443773b6368.tar.bz2
gentoo-2-98bd018cd51e772002f2943ea15bd443773b6368.zip
keystoneclient fix for upstream bug https://bugs.launchpad.net/opensuse/+bug/1181157
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-keystoneclient/ChangeLog10
-rw-r--r--dev-python/python-keystoneclient/files/0.2.3-upstream-1181157.patch47
-rw-r--r--dev-python/python-keystoneclient/python-keystoneclient-0.2.3-r1.ebuild (renamed from dev-python/python-keystoneclient/python-keystoneclient-0.2.3.ebuild)7
3 files changed, 61 insertions, 3 deletions
diff --git a/dev-python/python-keystoneclient/ChangeLog b/dev-python/python-keystoneclient/ChangeLog
index 25646b47c5cf..6de6bfe16134 100644
--- a/dev-python/python-keystoneclient/ChangeLog
+++ b/dev-python/python-keystoneclient/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/python-keystoneclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/ChangeLog,v 1.7 2013/05/24 14:26:58 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/ChangeLog,v 1.8 2013/05/24 14:46:37 prometheanfire Exp $
+
+*python-keystoneclient-0.2.3-r1 (24 May 2013)
+
+ 24 May 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +files/0.2.3-upstream-1181157.patch, +python-keystoneclient-0.2.3-r1.ebuild,
+ -python-keystoneclient-0.2.3.ebuild:
+ keystoneclient fix for upstream bug
+ https://bugs.launchpad.net/opensuse/+bug/1181157
*python-keystoneclient-0.2.3 (24 May 2013)
diff --git a/dev-python/python-keystoneclient/files/0.2.3-upstream-1181157.patch b/dev-python/python-keystoneclient/files/0.2.3-upstream-1181157.patch
new file mode 100644
index 000000000000..a94a88a9d174
--- /dev/null
+++ b/dev-python/python-keystoneclient/files/0.2.3-upstream-1181157.patch
@@ -0,0 +1,47 @@
+From 03012e641d6c2a98fbfe3780102e28a65d11a887 Mon Sep 17 00:00:00 2001
+From: Dolph Mathews <dolph.mathews@gmail.com>
+Date: Fri, 17 May 2013 10:38:25 -0500
+Subject: [PATCH] Default signing_dir to secure temp dir (bug 1181157)
+
+Change-Id: I1a29f50b07a60de3d0519bf40074dbea92fa8656
+---
+ keystoneclient/middleware/auth_token.py | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/keystoneclient/middleware/auth_token.py b/keystoneclient/middleware/auth_token.py
+index e6cf99f..befa79e 100644
+--- a/keystoneclient/middleware/auth_token.py
++++ b/keystoneclient/middleware/auth_token.py
+@@ -150,6 +150,7 @@ import json
+ import logging
+ import os
+ import stat
++import tempfile
+ import time
+ import urllib
+ import webob.exc
+@@ -211,8 +212,7 @@ opts = [
+ cfg.StrOpt('cache', default=None), # env key for the swift cache
+ cfg.StrOpt('certfile'),
+ cfg.StrOpt('keyfile'),
+- cfg.StrOpt('signing_dir',
+- default=os.path.expanduser('~/keystone-signing')),
++ cfg.StrOpt('signing_dir'),
+ cfg.ListOpt('memcache_servers'),
+ cfg.IntOpt('token_cache_time', default=300),
+ cfg.IntOpt('revocation_cache_time', default=1),
+@@ -292,8 +292,10 @@ class AuthProtocol(object):
+ self.cert_file = self._conf_get('certfile')
+ self.key_file = self._conf_get('keyfile')
+
+- #signing
++ # signing
+ self.signing_dirname = self._conf_get('signing_dir')
++ if self.signing_dirname is None:
++ self.signing_dirname = tempfile.mkdtemp(prefix='keystone-signing-')
+ self.LOG.info('Using %s as cache directory for signing certificate' %
+ self.signing_dirname)
+ if os.path.exists(self.signing_dirname):
+--
+1.8.1.5
+
diff --git a/dev-python/python-keystoneclient/python-keystoneclient-0.2.3.ebuild b/dev-python/python-keystoneclient/python-keystoneclient-0.2.3-r1.ebuild
index 355ae1006f80..5675829a4e45 100644
--- a/dev-python/python-keystoneclient/python-keystoneclient-0.2.3.ebuild
+++ b/dev-python/python-keystoneclient/python-keystoneclient-0.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-0.2.3.ebuild,v 1.1 2013/05/24 14:26:58 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-0.2.3-r1.ebuild,v 1.1 2013/05/24 14:46:37 prometheanfire Exp $
EAPI=5
#restricted due to packages missing and bad depends in the test ==webob-1.0.8
@@ -42,7 +42,10 @@ RDEPEND="dev-python/iso8601[${PYTHON_USEDEP}]
dev-python/simplejson[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]"
-PATCHES=( "${FILESDIR}/0.2.3-CVE-2013-2013.patch" )
+PATCHES=(
+ "${FILESDIR}/0.2.3-CVE-2013-2013.patch"
+ "${FILESDIR}/0.2.3-upstream-1181157.patch"
+ )
python_test() {
${PYTHON} setup.py nosetests || die