summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-24 17:16:03 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-24 17:16:03 +0000
commit96fe959ea99c3f6fc52521efa63234d6bc107144 (patch)
tree2b18f506d82e9e899e5ec3956181ce6cb6f06713 /dev-python
parentAdd fix for bug #262105, sparc-only (diff)
downloadgentoo-2-96fe959ea99c3f6fc52521efa63234d6bc107144.tar.gz
gentoo-2-96fe959ea99c3f6fc52521efa63234d6bc107144.tar.bz2
gentoo-2-96fe959ea99c3f6fc52521efa63234d6bc107144.zip
Improve error message.
(Portage version: 13625-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylibacl/ChangeLog6
-rw-r--r--dev-python/pylibacl/pylibacl-0.4.0.ebuild14
2 files changed, 16 insertions, 4 deletions
diff --git a/dev-python/pylibacl/ChangeLog b/dev-python/pylibacl/ChangeLog
index 9e2dc8340c2b..6f273f2774d6 100644
--- a/dev-python/pylibacl/ChangeLog
+++ b/dev-python/pylibacl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pylibacl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/ChangeLog,v 1.17 2009/05/23 13:21:07 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/ChangeLog,v 1.18 2009/05/24 17:16:03 arfrever Exp $
+
+ 24 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pylibacl-0.4.0.ebuild:
+ Improve error message.
23 May 2009; Brent Baude <ranger@gentoo.org> pylibacl-0.4.0.ebuild:
Backing off ppc64 kw for pylibacl-0.4.0
diff --git a/dev-python/pylibacl/pylibacl-0.4.0.ebuild b/dev-python/pylibacl/pylibacl-0.4.0.ebuild
index 7d1a76435eb6..9a511c93827e 100644
--- a/dev-python/pylibacl/pylibacl-0.4.0.ebuild
+++ b/dev-python/pylibacl/pylibacl-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/pylibacl-0.4.0.ebuild,v 1.5 2009/05/23 13:21:07 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/pylibacl-0.4.0.ebuild,v 1.6 2009/05/24 17:16:03 arfrever Exp $
inherit distutils
@@ -19,6 +19,14 @@ DEPEND="${RDEPEND}
>=dev-python/setuptools-0.6_rc7-r1"
src_test() {
- PYTHONPATH="$(ls -d build/lib*)" python test/test_acls.py ||\
- die "tests failed"
+ PYTHONPATH="$(ls -d build/lib*)" python test/test_acls.py || \
+ {
+ eerror
+ eerror "If you got the following errors:"
+ eerror "\"IOError: [Errno 95] Operation not supported\","
+ eerror "then you should remount the filesystem containing"
+ eerror "build directory with \"acl\" option enabled."
+ eerror
+ die "tests failed"
+ }
}