summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-09 09:12:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-09 09:12:03 +0000
commit91506bb7f262220e9cd86430b7d43417afb5023e (patch)
treedc4486d9b1b9017a7c449f513e6154d47b26bba4 /dev-python
parentx86 stable wrt bug #400195 (diff)
downloadgentoo-2-91506bb7f262220e9cd86430b7d43417afb5023e.tar.gz
gentoo-2-91506bb7f262220e9cd86430b7d43417afb5023e.tar.bz2
gentoo-2-91506bb7f262220e9cd86430b7d43417afb5023e.zip
Bump
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/spyder/ChangeLog7
-rw-r--r--dev-python/spyder/spyder-2.1.7.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-python/spyder/ChangeLog b/dev-python/spyder/ChangeLog
index 69432f6e6824..8c60afc8ef6e 100644
--- a/dev-python/spyder/ChangeLog
+++ b/dev-python/spyder/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/spyder
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.25 2012/02/25 01:58:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.26 2012/03/09 09:12:03 patrick Exp $
+
+*spyder-2.1.7 (09 Mar 2012)
+
+ 09 Mar 2012; Patrick Lauer <patrick@gentoo.org> +spyder-2.1.7.ebuild:
+ Bump
25 Feb 2012; Patrick Lauer <patrick@gentoo.org> spyder-2.1.2.ebuild,
spyder-2.1.6.ebuild:
diff --git a/dev-python/spyder/spyder-2.1.7.ebuild b/dev-python/spyder/spyder-2.1.7.ebuild
new file mode 100644
index 000000000000..bef9ade1604f
--- /dev/null
+++ b/dev-python/spyder/spyder-2.1.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.1.7.ebuild,v 1.1 2012/03/09 09:12:03 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python IDE with matlab-like features"
+HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
+SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ipython matplotlib numpy pep8 +pyflakes pylint +rope scipy sphinx"
+
+RDEPEND=">=dev-python/PyQt4-4.4[webkit]
+ ipython? ( dev-python/ipython )
+ matplotlib? ( dev-python/matplotlib )
+ numpy? ( dev-python/numpy )
+ pep8? ( dev-python/pep8 )
+ pyflakes? ( >=dev-python/pyflakes-0.3 )
+ pylint? ( dev-python/pylint )
+ rope? ( >=dev-python/rope-0.9.3 )
+ scipy? ( sci-libs/scipy )
+ sphinx? ( dev-python/sphinx )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+PYTHON_MODNAME="spyderlib spyderplugins"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-2.1.2-disable_sphinx_dependency.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH="build-$(PYTHON -f --ABI)" \
+ sphinx-build doc doc_output || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ doicon spyderlib/images/spyder.svg || die
+ make_desktop_entry spyder Spyder spyder "Development;IDE"
+ if use doc; then
+ pushd doc_output > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _images _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}