summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-11-23 22:18:06 +0000
committerMichał Górny <mgorny@gentoo.org>2012-11-23 22:18:06 +0000
commit8cb3baaf162a2221a284bdf536b9a806200a28b4 (patch)
tree683e6e7d6d4be124a9bfe2a213dc1d8805b12703 /dev-python
parentVersion bump, add systemd service description by Emery Hemingway (bug 442064)... (diff)
downloadgentoo-2-8cb3baaf162a2221a284bdf536b9a806200a28b4.tar.gz
gentoo-2-8cb3baaf162a2221a284bdf536b9a806200a28b4.tar.bz2
gentoo-2-8cb3baaf162a2221a284bdf536b9a806200a28b4.zip
Version bump. The new version supports running the wrapper through Python (bug #438984).
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-exec/ChangeLog8
-rw-r--r--dev-python/python-exec/python-exec-0.2.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/python-exec/ChangeLog b/dev-python/python-exec/ChangeLog
index 16ae6eea70e4..1ba2b2d0a477 100644
--- a/dev-python/python-exec/ChangeLog
+++ b/dev-python/python-exec/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-exec
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/ChangeLog,v 1.10 2012/10/31 23:40:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/ChangeLog,v 1.11 2012/11/23 22:18:06 mgorny Exp $
+
+*python-exec-0.2 (23 Nov 2012)
+
+ 23 Nov 2012; Michał Górny <mgorny@gentoo.org> +python-exec-0.2.ebuild:
+ Version bump. The new version supports running the wrapper through Python (bug
+ #438984).
*python-exec-0.1.1 (31 Oct 2012)
diff --git a/dev-python/python-exec/python-exec-0.2.ebuild b/dev-python/python-exec/python-exec-0.2.ebuild
new file mode 100644
index 000000000000..daf6b74d8627
--- /dev/null
+++ b/dev-python/python-exec/python-exec-0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/python-exec-0.2.ebuild,v 1.1 2012/11/23 22:18:06 mgorny Exp $
+
+EAPI=4
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+append_impl() {
+ pyimpls+="${EPYTHON} "
+}
+
+src_configure() {
+ local pyimpls
+ python_foreach_impl append_impl
+
+ local myeconfargs=(
+ --with-eprefix="${EPREFIX}"
+ --with-python-impls="${pyimpls}"
+ )
+
+ autotools-utils_src_configure
+}