summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-31 11:19:52 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-31 11:19:52 +0000
commit8a917da13e6d5ef3a17e8a2d42a4a7a4bd228ad1 (patch)
treefa74d64e82089e15e14a116d32131c88ab56141f /dev-python
parentVersion bump to accompany gnucash 2.6.5. (diff)
downloadgentoo-2-8a917da13e6d5ef3a17e8a2d42a4a7a4bd228ad1.tar.gz
gentoo-2-8a917da13e6d5ef3a17e8a2d42a4a7a4bd228ad1.tar.bz2
gentoo-2-8a917da13e6d5ef3a17e8a2d42a4a7a4bd228ad1.zip
revbump; conversion -> distutils-r1
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyao/ChangeLog10
-rw-r--r--dev-python/pyao/pyao-0.82-r3.ebuild27
2 files changed, 34 insertions, 3 deletions
diff --git a/dev-python/pyao/ChangeLog b/dev-python/pyao/ChangeLog
index fe1946173859..17d30755a9ad 100644
--- a/dev-python/pyao/ChangeLog
+++ b/dev-python/pyao/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyao
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyao/ChangeLog,v 1.20 2012/02/21 08:49:16 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyao/ChangeLog,v 1.21 2014/12/31 11:19:52 idella4 Exp $
+
+*pyao-0.82-r3 (31 Dec 2014)
+
+ 31 Dec 2014; Ian Delaney <idella4@gentoo.org> +pyao-0.82-r3.ebuild:
+ revbump; conversion -> distutils-r1
21 Feb 2012; Patrick Lauer <patrick@gentoo.org> pyao-0.82-r2.ebuild:
Restricting jython
@@ -69,4 +74,3 @@
02 Mar 2003; Alastair Tse <liquidx@gentoo.org> pyao-0.81.ebuild files/digest-pyao-0.81 :
Initial Ebuild. Thanks to mike wakerly <mikew@wakerly.com>. Resolves #15979.
-
diff --git a/dev-python/pyao/pyao-0.82-r3.ebuild b/dev-python/pyao/pyao-0.82-r3.ebuild
new file mode 100644
index 000000000000..b0ce8a0e95a2
--- /dev/null
+++ b/dev-python/pyao/pyao-0.82-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyao/pyao-0.82-r3.ebuild,v 1.1 2014/12/31 11:19:52 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the libao library"
+HOMEPAGE="http://www.andrewchatham.com/pyogg/"
+SRC_URI="http://www.andrewchatham.com/pyogg/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc -sparc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libao-1.0.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-new_api.patch )
+
+python_compile() {
+ "${PYTHON}" config_unix.py || die
+ distutils-r1_python_compile
+}