summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-10-27 08:24:44 +0000
committerMichał Górny <mgorny@gentoo.org>2013-10-27 08:24:44 +0000
commit87955fd5614357a4dd75c949017173cd84160092 (patch)
treeeb823b33eb4a6f22ac6d92ca3fb1043b3aa64ecf /dev-python
parentRemove redundant python_export_best (done by the eclass). Fix eclass use. (diff)
downloadgentoo-2-87955fd5614357a4dd75c949017173cd84160092.tar.gz
gentoo-2-87955fd5614357a4dd75c949017173cd84160092.tar.bz2
gentoo-2-87955fd5614357a4dd75c949017173cd84160092.zip
Remove redundant python_export_best (done by the eclass). Fix eclass use.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyplusplus/ChangeLog6
-rw-r--r--dev-python/pyplusplus/pyplusplus-1.0.0-r1.ebuild19
-rw-r--r--dev-python/pyplusplus/pyplusplus-1.0.0.ebuild19
3 files changed, 19 insertions, 25 deletions
diff --git a/dev-python/pyplusplus/ChangeLog b/dev-python/pyplusplus/ChangeLog
index 7e96ec8d80d4..6741f6a5ccbf 100644
--- a/dev-python/pyplusplus/ChangeLog
+++ b/dev-python/pyplusplus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyplusplus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyplusplus/ChangeLog,v 1.2 2013/09/16 11:59:54 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyplusplus/ChangeLog,v 1.3 2013/10/27 08:24:44 mgorny Exp $
+
+ 27 Oct 2013; Michał Górny <mgorny@gentoo.org> pyplusplus-1.0.0-r1.ebuild,
+ pyplusplus-1.0.0.ebuild:
+ Remove redundant python_export_best (done by the eclass). Fix eclass use.
*pyplusplus-1.0.0-r1 (16 Sep 2013)
diff --git a/dev-python/pyplusplus/pyplusplus-1.0.0-r1.ebuild b/dev-python/pyplusplus/pyplusplus-1.0.0-r1.ebuild
index cbf41ecc9b33..307a2412842b 100644
--- a/dev-python/pyplusplus/pyplusplus-1.0.0-r1.ebuild
+++ b/dev-python/pyplusplus/pyplusplus-1.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyplusplus/pyplusplus-1.0.0-r1.ebuild,v 1.1 2013/09/16 11:59:54 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyplusplus/pyplusplus-1.0.0-r1.ebuild,v 1.2 2013/10/27 08:24:43 mgorny Exp $
EAPI=5
@@ -17,30 +17,25 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples +indexing"
-DEPEND="doc? ( >=dev-python/epydoc-3 )
+DEPEND="doc? ( >=dev-python/epydoc-3[${PYTHON_USEDEP}] )
app-arch/unzip"
-RDEPEND="=dev-python/pygccxml-1.0.0"
+RDEPEND="=dev-python/pygccxml-1.0.0[${PYTHON_USEDEP}]"
S=${WORKDIR}/Py++-${PV}
python_compile_all() {
if use doc; then
- python_export_best
- "$(PYTHON)" setup.py doc
+ esetup.py doc
fi
}
python_test() {
- "$(PYTHON)" unittests/test_all.py
+ "${PYTHON}" unittests/test_all.py
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/documentation/apidocs/* )
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
+ use doc && local HTML_DOCS=( docs/documentation/apidocs/. )
+ use examples && local EXAMPLES=( examples/. )
if use indexing; then
insinto /usr/include/boost/python/suite/indexing
diff --git a/dev-python/pyplusplus/pyplusplus-1.0.0.ebuild b/dev-python/pyplusplus/pyplusplus-1.0.0.ebuild
index b1a9b36416a8..925a2a64c1c9 100644
--- a/dev-python/pyplusplus/pyplusplus-1.0.0.ebuild
+++ b/dev-python/pyplusplus/pyplusplus-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyplusplus/pyplusplus-1.0.0.ebuild,v 1.1 2013/08/30 10:49:59 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyplusplus/pyplusplus-1.0.0.ebuild,v 1.2 2013/10/27 08:24:43 mgorny Exp $
EAPI=5
@@ -17,30 +17,25 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples"
-DEPEND="doc? ( >=dev-python/epydoc-3 )
+DEPEND="doc? ( >=dev-python/epydoc-3[${PYTHON_USEDEP}] )
app-arch/unzip"
-RDEPEND="=dev-python/pygccxml-1.0.0"
+RDEPEND="=dev-python/pygccxml-1.0.0[${PYTHON_USEDEP}]"
S=${WORKDIR}/Py++-${PV}
python_compile_all() {
if use doc; then
- python_export_best
- "$(PYTHON)" setup.py doc
+ esetup.py doc
fi
}
python_test() {
- "$(PYTHON)" unittests/test_all.py
+ "${PYTHON}" unittests/test_all.py
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/documentation/apidocs/* )
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
+ use doc && local HTML_DOCS=( docs/documentation/apidocs/. )
+ use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
}