summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-08 17:57:19 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-08 17:57:19 +0000
commit85522f0c0b5ff49c15d8e6e12d987485b9b5911f (patch)
tree5cff0552e74b54e261bca8deefa9093d6c8b1d48 /dev-python
parentversion bump (diff)
downloadgentoo-2-85522f0c0b5ff49c15d8e6e12d987485b9b5911f.tar.gz
gentoo-2-85522f0c0b5ff49c15d8e6e12d987485b9b5911f.tar.bz2
gentoo-2-85522f0c0b5ff49c15d8e6e12d987485b9b5911f.zip
Set SUPPORT_PYTHON_ABIS. Fix dependencies.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/subunit/ChangeLog6
-rw-r--r--dev-python/subunit/subunit-0.0.5.ebuild23
2 files changed, 19 insertions, 10 deletions
diff --git a/dev-python/subunit/ChangeLog b/dev-python/subunit/ChangeLog
index 73a4b1a7a5ce..535659e98ace 100644
--- a/dev-python/subunit/ChangeLog
+++ b/dev-python/subunit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/subunit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.1 2010/04/08 07:39:25 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.2 2010/04/08 17:57:19 arfrever Exp $
+
+ 08 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ subunit-0.0.5.ebuild:
+ Set SUPPORT_PYTHON_ABIS. Fix dependencies.
*subunit-0.0.5 (08 Apr 2010)
diff --git a/dev-python/subunit/subunit-0.0.5.ebuild b/dev-python/subunit/subunit-0.0.5.ebuild
index 7a99b793312b..8ddc7e83e22c 100644
--- a/dev-python/subunit/subunit-0.0.5.ebuild
+++ b/dev-python/subunit/subunit-0.0.5.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.5.ebuild,v 1.1 2010/04/08 07:39:25 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.5.ebuild,v 1.2 2010/04/08 17:57:19 arfrever Exp $
-PYTHON_DEPEND="2:2.6"
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
inherit python
@@ -15,16 +18,18 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE=""
-DEPEND="dev-python/testtools
- dev-util/cppunit
+RDEPEND="dev-python/testtools"
+DEPEND="${RDEPEND}
dev-lang/perl
+ dev-libs/check
+ dev-util/cppunit
dev-util/pkgconfig"
-RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
-pkg_setup() {
- python_set_active_version 2
+pkg_postinst() {
+ python_mod_optimize subunit
}
-src_install() {
- emake install DESTDIR="${D}"|| die
+pkg_postrm() {
+ python_mod_cleanup subunit
}