summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-04-06 15:25:21 +0000
committerMike Gilbert <floppym@gentoo.org>2013-04-06 15:25:21 +0000
commit8339a8df3d6671ea07cbbc45949945c701cac47d (patch)
treea5e516b97c6e076695705b2bb8312d4e2f307389 /dev-python
parentfixed 'keepTracks is initialized too late in the cDevice' (diff)
downloadgentoo-2-8339a8df3d6671ea07cbbc45949945c701cac47d.tar.gz
gentoo-2-8339a8df3d6671ea07cbbc45949945c701cac47d.tar.bz2
gentoo-2-8339a8df3d6671ea07cbbc45949945c701cac47d.zip
Simplify python_test a bit.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ipy/ChangeLog5
-rw-r--r--dev-python/ipy/ipy-0.76-r1.ebuild20
2 files changed, 10 insertions, 15 deletions
diff --git a/dev-python/ipy/ChangeLog b/dev-python/ipy/ChangeLog
index 0fe39f51de00..305e48be434e 100644
--- a/dev-python/ipy/ChangeLog
+++ b/dev-python/ipy/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/ipy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ChangeLog,v 1.37 2013/04/06 14:39:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ChangeLog,v 1.38 2013/04/06 15:25:21 floppym Exp $
+
+ 06 Apr 2013; Mike Gilbert <floppym@gentoo.org> ipy-0.76-r1.ebuild:
+ Simplify python_test a bit.
06 Apr 2013; Ian Delaney <idella4@gentoo.org> ipy-0.76-r1.ebuild:
add die to calls to python
diff --git a/dev-python/ipy/ipy-0.76-r1.ebuild b/dev-python/ipy/ipy-0.76-r1.ebuild
index 3a7590cf697d..6a6c950936d7 100644
--- a/dev-python/ipy/ipy-0.76-r1.ebuild
+++ b/dev-python/ipy/ipy-0.76-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.76-r1.ebuild,v 1.2 2013/04/06 14:39:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.76-r1.ebuild,v 1.3 2013/04/06 15:25:21 floppym Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} pypy2_0 )
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
inherit distutils-r1
@@ -27,17 +27,9 @@ S="${WORKDIR}/${MY_P}"
DOCS=( ChangeLog README )
python_test() {
- "${PYTHON}" test/test_IPy.py || die
# doctests for py3 unaltered read py2 files from "${S}" causing total failure
- if [[ ${EPYTHON} == python3* ]]; then
- cd "${BUILD_DIR}/lib" || die
- cp -r "${S}"/{README,test_doc.py} . || die
- mkdir test && cp -r "${S}"/test/test.rst test/ || die
- "${PYTHON}" test_doc.py || die
- # If left these files are wrongly installed; tidy up
- rm -f ./{README,test_doc.py,test/test.rst} && rmdir test || die
- else
- "${PYTHON}" test_doc.py || die
- fi
- einfo "tests passed under ${EPYTHON}"
+ cp -r test_doc.py README test "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ "${PYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
+ "${PYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
}