summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-12-10 18:56:32 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-12-10 18:56:32 +0000
commit76e6a534320fffdc3cd4e52267b461d24eec0367 (patch)
tree88eee73217f89865dc7150adc0976bfbd8c1e89c /dev-python
parentStabilize for all #393949 by Paweł Hajdan. (diff)
downloadgentoo-2-76e6a534320fffdc3cd4e52267b461d24eec0367.tar.gz
gentoo-2-76e6a534320fffdc3cd4e52267b461d24eec0367.tar.bz2
gentoo-2-76e6a534320fffdc3cd4e52267b461d24eec0367.zip
Version bump thanks to Arfrever
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-docs/ChangeLog12
-rw-r--r--dev-python/python-docs/python-docs-2.6.7.ebuild33
-rw-r--r--dev-python/python-docs/python-docs-2.7.2.ebuild33
-rw-r--r--dev-python/python-docs/python-docs-3.1.4.ebuild33
-rw-r--r--dev-python/python-docs/python-docs-3.2.2.ebuild33
5 files changed, 143 insertions, 1 deletions
diff --git a/dev-python/python-docs/ChangeLog b/dev-python/python-docs/ChangeLog
index 2e134082eb4f..0642990ab2e2 100644
--- a/dev-python/python-docs/ChangeLog
+++ b/dev-python/python-docs/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-python/python-docs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.159 2011/11/28 19:52:06 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.160 2011/12/10 18:56:32 hwoarang Exp $
+
+*python-docs-2.7.2 (10 Dec 2011)
+*python-docs-2.6.7 (10 Dec 2011)
+*python-docs-3.1.4 (10 Dec 2011)
+*python-docs-3.2.2 (10 Dec 2011)
+
+ 10 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +python-docs-2.6.7.ebuild,
+ +python-docs-2.7.2.ebuild, +python-docs-3.1.4.ebuild,
+ +python-docs-3.2.2.ebuild:
+ Version bump thanks to Arfrever
28 Nov 2011; Markos Chandras <hwoarang@gentoo.org>
python-docs-2.4.4-r1.ebuild, python-docs-2.5.4-r1.ebuild,
diff --git a/dev-python/python-docs/python-docs-2.6.7.ebuild b/dev-python/python-docs/python-docs-2.6.7.ebuild
new file mode 100644
index 000000000000..7183cb245e69
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.6.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.6.7.ebuild,v 1.1 2011/12/10 18:56:32 hwoarang Exp $
+
+EAPI="3"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+pkg_postrm() {
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}
diff --git a/dev-python/python-docs/python-docs-2.7.2.ebuild b/dev-python/python-docs/python-docs-2.7.2.ebuild
new file mode 100644
index 000000000000..ec7646ceb264
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.7.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.7.2.ebuild,v 1.1 2011/12/10 18:56:32 hwoarang Exp $
+
+EAPI="3"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="2.7"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+pkg_postrm() {
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}
diff --git a/dev-python/python-docs/python-docs-3.1.4.ebuild b/dev-python/python-docs/python-docs-3.1.4.ebuild
new file mode 100644
index 000000000000..7856fcad7183
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.1.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.1.4.ebuild,v 1.1 2011/12/10 18:56:32 hwoarang Exp $
+
+EAPI="3"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="3.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+pkg_postrm() {
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}
diff --git a/dev-python/python-docs/python-docs-3.2.2.ebuild b/dev-python/python-docs/python-docs-3.2.2.ebuild
new file mode 100644
index 000000000000..c444f9b55dab
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.2.2.ebuild,v 1.1 2011/12/10 18:56:32 hwoarang Exp $
+
+EAPI="3"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="3.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+pkg_postrm() {
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}