summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2011-05-27 18:21:44 +0000
committerTomás Touceda <chiiph@gentoo.org>2011-05-27 18:21:44 +0000
commit763049d0203cd2bdb697e81cd5888c19b0bd7fa5 (patch)
tree4fa6e0e73858787694b29d9adf7d3c235e873d2d /dev-python
parentVersion bump (diff)
downloadgentoo-2-763049d0203cd2bdb697e81cd5888c19b0bd7fa5.tar.gz
gentoo-2-763049d0203cd2bdb697e81cd5888c19b0bd7fa5.tar.bz2
gentoo-2-763049d0203cd2bdb697e81cd5888c19b0bd7fa5.zip
Version bump
(Portage version: 2.2.0_alpha29/cvs/Linux i686)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/shiboken/ChangeLog8
-rw-r--r--dev-python/shiboken/files/shiboken-1.0.3-fix-pkgconfig.patch20
-rw-r--r--dev-python/shiboken/shiboken-1.0.3.ebuild40
3 files changed, 67 insertions, 1 deletions
diff --git a/dev-python/shiboken/ChangeLog b/dev-python/shiboken/ChangeLog
index 107bc896facd..b94de74c0b50 100644
--- a/dev-python/shiboken/ChangeLog
+++ b/dev-python/shiboken/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/shiboken
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.8 2011/03/20 19:58:45 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.9 2011/05/27 18:21:44 chiiph Exp $
+
+*shiboken-1.0.3 (27 May 2011)
+
+ 27 May 2011; Tomas Touceda <chiiph@gentoo.org> +shiboken-1.0.3.ebuild,
+ +files/shiboken-1.0.3-fix-pkgconfig.patch:
+ Version bump
*shiboken-1.0.0 (20 Mar 2011)
diff --git a/dev-python/shiboken/files/shiboken-1.0.3-fix-pkgconfig.patch b/dev-python/shiboken/files/shiboken-1.0.3-fix-pkgconfig.patch
new file mode 100644
index 000000000000..208ec2579827
--- /dev/null
+++ b/dev-python/shiboken/files/shiboken-1.0.3-fix-pkgconfig.patch
@@ -0,0 +1,20 @@
+diff -Naur shiboken-1.0.0~beta5.orig/data/shiboken.pc.in shiboken-1.0.0~beta5/data/shiboken.pc.in
+--- shiboken-1.0.0~beta5.orig/data/shiboken.pc.in 2011-02-02 11:39:04.000000000 -0300
++++ shiboken-1.0.0~beta5/data/shiboken.pc.in 2011-02-17 11:06:16.843572611 -0300
+@@ -1,7 +1,8 @@
+ prefix=@CMAKE_INSTALL_PREFIX@
+ exec_prefix=@CMAKE_INSTALL_PREFIX@
+ libdir=@LIB_INSTALL_DIR@
+-includedir=@CMAKE_INSTALL_PREFIX@/include/shiboken
++shiboken_SUFFIX=@shiboken_SUFFIX@
++includedir=@CMAKE_INSTALL_PREFIX@/include/shiboken${shiboken_SUFFIX}
+ generator_location=@CMAKE_INSTALL_PREFIX@/bin/@SHIBOKEN_GENERATOR@
+ python_interpreter=@PYTHON_EXECUTABLE@
+ python_include_dir=@SBK_PYTHON_INCLUDE_DIR@
+@@ -11,5 +12,5 @@
+ Description: Support library for Python bindings created with Shiboken generator.
+ Version: @shiboken_VERSION@
+ Libs: @SBK_PYTHON_LIBRARIES@ -L${libdir} -lshiboken@shiboken_SUFFIX@@LIBRARY_OUTPUT_SUFFIX@
+-Cflags: -I@SBK_PYTHON_INCLUDE_DIR@ -I${includedir}/@shiboken_SUFFIX@@SBK_PKG_CONFIG_PY_DEBUG_DEFINITION@
++Cflags: -I@SBK_PYTHON_INCLUDE_DIR@ -I${includedir}/
+
diff --git a/dev-python/shiboken/shiboken-1.0.3.ebuild b/dev-python/shiboken/shiboken-1.0.3.ebuild
new file mode 100644
index 000000000000..f3ed6df3a85b
--- /dev/null
+++ b/dev-python/shiboken/shiboken-1.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.0.3.ebuild,v 1.1 2011/05/27 18:21:44 chiiph Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2:2.5"
+
+inherit cmake-utils python versionator
+
+MY_PV=$(replace_version_separator '_' '~')
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="A tool for creating Python bindings for C++ libraries"
+HOMEPAGE="http://www.pyside.org/"
+SRC_URI="http://www.pyside.org/files/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=dev-python/apiextractor-0.8.1
+ >=dev-python/generatorrunner-0.6.1
+ >=x11-libs/qt-core-4.5.0"
+RDEPEND="${DEPEND}
+ !dev-python/boostpythongenerator"
+
+PATCHES=( "${FILESDIR}/${P}-fix-pkgconfig.patch" )
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog || die "dodoc failed"
+}