summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-07-06 12:49:18 +0000
committerMichał Górny <mgorny@gentoo.org>2014-07-06 12:49:18 +0000
commit757d30f23ddc08529489a92c2128a57262f61d8e (patch)
treec2c511038b88b95913d0c3c62836a7cb55d9b4fa /dev-python
parentClean up obsolete dependencies on virtual/python-argparse and virtual/python-... (diff)
downloadgentoo-2-757d30f23ddc08529489a92c2128a57262f61d8e.tar.gz
gentoo-2-757d30f23ddc08529489a92c2128a57262f61d8e.tar.bz2
gentoo-2-757d30f23ddc08529489a92c2128a57262f61d8e.zip
Clean up obsolete dependencies on virtual/python-argparse and virtual/python-unittest2 (those packages were only required for <=python-2.6).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest/ChangeLog7
-rw-r--r--dev-python/pytest/pytest-2.4.2.ebuild3
-rw-r--r--dev-python/pytest/pytest-2.5.2.ebuild3
3 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index 5474aa1a5b4b..00bdf2492a84 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.89 2014/04/02 20:25:31 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.90 2014/07/06 12:49:18 mgorny Exp $
+
+ 06 Jul 2014; Michał Górny <mgorny@gentoo.org> pytest-2.4.2.ebuild,
+ pytest-2.5.2.ebuild:
+ Clean up obsolete dependencies on virtual/python-argparse and virtual/python-
+ unittest2 (those packages were only required for <=python-2.6).
02 Apr 2014; Tim Harder <radhermit@gentoo.org> pytest-2.5.2.ebuild:
Add python3_4 support.
diff --git a/dev-python/pytest/pytest-2.4.2.ebuild b/dev-python/pytest/pytest-2.4.2.ebuild
index 2f91cf3346a1..8468dd8f9960 100644
--- a/dev-python/pytest/pytest-2.4.2.ebuild
+++ b/dev-python/pytest/pytest-2.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 1.9 2014/03/31 20:31:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 1.10 2014/07/06 12:49:18 mgorny Exp $
EAPI="5"
@@ -23,7 +23,6 @@ RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
#pexpect dep based on https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/python-argparse[${PYTHON_USEDEP}]
test? (
dev-python/pexpect[$(python_gen_usedep python{2_6,2_7,3_2,3_3})]
dev-python/pyyaml[${PYTHON_USEDEP}]
diff --git a/dev-python/pytest/pytest-2.5.2.ebuild b/dev-python/pytest/pytest-2.5.2.ebuild
index 3c99d9e4d3f6..a6b1f9c465df 100644
--- a/dev-python/pytest/pytest-2.5.2.ebuild
+++ b/dev-python/pytest/pytest-2.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild,v 1.4 2014/04/02 20:25:31 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild,v 1.5 2014/07/06 12:49:18 mgorny Exp $
EAPI="5"
@@ -23,7 +23,6 @@ RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
#pexpect dep based on https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/python-argparse[${PYTHON_USEDEP}]
test? (
dev-python/pexpect[$(python_gen_usedep python{2_6,2_7,3_2,3_3,3_4})]
dev-python/pyyaml[${PYTHON_USEDEP}]