summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-31 05:27:11 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-31 05:27:11 +0000
commit700a88af52e15afcf11cc486c37b8ce674edb617 (patch)
tree1c7a2853ea9846089f3903249bbf90e39de7fd40 /dev-python
parentQA: Remove package with invalid copyright (diff)
downloadgentoo-2-700a88af52e15afcf11cc486c37b8ce674edb617.tar.gz
gentoo-2-700a88af52e15afcf11cc486c37b8ce674edb617.tar.bz2
gentoo-2-700a88af52e15afcf11cc486c37b8ce674edb617.zip
clean old impls, bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/zope-interface/ChangeLog7
-rw-r--r--dev-python/zope-interface/zope-interface-4.1.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/zope-interface/ChangeLog b/dev-python/zope-interface/ChangeLog
index e0165d01011f..f362260b41fd 100644
--- a/dev-python/zope-interface/ChangeLog
+++ b/dev-python/zope-interface/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/zope-interface
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/zope-interface/ChangeLog,v 1.1 2014/12/12 23:22:51 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/zope-interface/ChangeLog,v 1.2 2014/12/31 05:27:11 idella4 Exp $
+
+*zope-interface-4.1.2 (31 Dec 2014)
+
+ 31 Dec 2014; Ian Delaney <idella4@gentoo.org> +zope-interface-4.1.2.ebuild:
+ clean old impls, bump
*zope-interface-4.1.1 (12 Dec 2014)
diff --git a/dev-python/zope-interface/zope-interface-4.1.2.ebuild b/dev-python/zope-interface/zope-interface-4.1.2.ebuild
new file mode 100644
index 000000000000..c33389a9b1f9
--- /dev/null
+++ b/dev-python/zope-interface/zope-interface-4.1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/zope-interface/zope-interface-4.1.2.ebuild,v 1.1 2014/12/31 05:27:11 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Interfaces for Python"
+HOMEPAGE="http://pypi.python.org/pypi/zope.interface"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 \
+~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+# until all deps are in the tree (bug #442794)
+RESTRICT="test"
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+ append-flags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}