summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-03-16 14:27:10 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-03-16 14:27:10 +0000
commit6f6be2de28f524a0967e2aca39df3c4fb4298d82 (patch)
treee75a3f5308aef84720a79d77c3ba9a814476aa8b /dev-python
parentamd64 stable (diff)
downloadgentoo-2-6f6be2de28f524a0967e2aca39df3c4fb4298d82.tar.gz
gentoo-2-6f6be2de28f524a0967e2aca39df3c4fb4298d82.tar.bz2
gentoo-2-6f6be2de28f524a0967e2aca39df3c4fb4298d82.zip
Fix modules getting installed into lib rather than lib64 on multilib
systems w/ python-2.4. (Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxpython/ChangeLog7
-rw-r--r--dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild18
-rw-r--r--dev-python/wxpython/wxpython-2.8.7.1.ebuild17
3 files changed, 22 insertions, 20 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index d087f2200755..145516f39067 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wxpython
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.84 2008/01/29 19:25:02 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.85 2008/03/16 14:27:10 dirtyepic Exp $
+
+ 16 Mar 2008; Ryan Hill <dirtyepic@gentoo.org> wxpython-2.6.4.0-r1.ebuild,
+ wxpython-2.8.7.1.ebuild:
+ Fix modules getting installed into lib rather than lib64 on multilib
+ systems w/ python-2.4.
29 Jan 2008; nixnut <nixnut@gentoo.org> wxpython-2.6.4.0-r1.ebuild,
wxpython-2.8.7.1.ebuild:
diff --git a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
index dd0cc86f3045..13b98b8d7d5f 100644
--- a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
@@ -1,11 +1,14 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.10 2008/01/29 19:25:02 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.11 2008/03/16 14:27:10 dirtyepic Exp $
EAPI=1
inherit alternatives eutils multilib python wxwidgets
+# Note, we don't use distutils.eclass because it doesn't seem to play nice with
+# need-wxwidgets
+
MY_P="${P/wxpython-/wxPython-src-}"
DESCRIPTION="A blending of the wxWindows C++ class library with Python"
HOMEPAGE="http://www.wxpython.org/"
@@ -70,27 +73,22 @@ src_install() {
python_version
local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
- dodir ${site_pkgs}
-
mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \
&& mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
|| mypyconf="${mypyconf} BUILD_GLCANVAS=0"
-
use unicode \
&& mypyconf="${mypyconf} UNICODE=1" \
|| mypyconf="${mypyconf} UNICODE=0"
mypyconf="${mypyconf} WXPORT=gtk2"
- python setup.py ${mypyconf} install --prefix=/usr --root="${D}" \
- || die "setup.py install failed"
+ python setup.py ${mypyconf} install --root="${D}" \
+ --install-purelib ${site_pkgs} || die "setup.py install failed"
# Collision protection.
- for file in \
- "${D}"/usr/bin/* \
- "${D}"/${site_pkgs}/wx{version.*,.pth,addons}; do
- mv "${file}" "${file}-${SLOT}"
+ for file in "${D}"/usr/bin/* "${D}"/${site_pkgs}/wx{version.*,.pth,addons}; do
+ mv "${file}" "${file}-${SLOT}"
done
}
diff --git a/dev-python/wxpython/wxpython-2.8.7.1.ebuild b/dev-python/wxpython/wxpython-2.8.7.1.ebuild
index bdb80f3013ae..adc57c5a18b4 100644
--- a/dev-python/wxpython/wxpython-2.8.7.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.7.1.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.7.1.ebuild,v 1.7 2008/01/29 19:25:02 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.7.1.ebuild,v 1.8 2008/03/16 14:27:10 dirtyepic Exp $
EAPI="1"
WX_GTK_VER="2.8"
inherit alternatives eutils multilib python wxwidgets
+# Note, we don't use distutils.eclass because it doesn't seem to play nice with
+# need-wxwidgets
+
MY_P="${P/wxpython-/wxPython-src-}"
DESCRIPTION="A blending of the wxWindows C++ class library with Python"
HOMEPAGE="http://www.wxpython.org/"
@@ -62,8 +65,6 @@ src_install() {
python_version
local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
- dodir ${site_pkgs}
-
mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \
&& mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
@@ -71,14 +72,12 @@ src_install() {
mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
- python setup.py ${mypyconf} install --prefix=/usr --root="${D}" \
- || die "setup.py install failed"
+ python setup.py ${mypyconf} install --root="${D}" \
+ --install-purelib ${site_pkgs} || die "setup.py install failed"
# Collision protection.
- for file in \
- "${D}"/usr/bin/* \
- "${D}"/${site_pkgs}/wx{version.*,.pth,addons}; do
- mv "${file}" "${file}-${SLOT}"
+ for file in "${D}"/usr/bin/* "${D}"/${site_pkgs}/wx{version.*,.pth,addons}; do
+ mv "${file}" "${file}-${SLOT}"
done
}