summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-20 18:53:55 +0000
committerMike Frysinger <vapier@gentoo.org>2015-02-20 18:53:55 +0000
commit6ec3d8b6ee187ef794043a60101195cdb64e9d14 (patch)
treeba97d8363f2d8a2bb180bdd024d000f208591891 /dev-python
parentTransform lohit-fonts into a meta ebuild to pull in all individual lohit font... (diff)
downloadgentoo-2-6ec3d8b6ee187ef794043a60101195cdb64e9d14.tar.gz
gentoo-2-6ec3d8b6ee187ef794043a60101195cdb64e9d14.tar.bz2
gentoo-2-6ec3d8b6ee187ef794043a60101195cdb64e9d14.zip
Fix from Chromium OS for cross-compiling.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/imaging/ChangeLog8
-rw-r--r--dev-python/imaging/files/imaging-1.1.7-no-host-paths.patch29
-rw-r--r--dev-python/imaging/imaging-1.1.7-r5.ebuild5
3 files changed, 38 insertions, 4 deletions
diff --git a/dev-python/imaging/ChangeLog b/dev-python/imaging/ChangeLog
index 8cdbbd2cd570..19bb7a210e32 100644
--- a/dev-python/imaging/ChangeLog
+++ b/dev-python/imaging/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/imaging
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/ChangeLog,v 1.95 2014/12/30 18:23:18 floppym Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/ChangeLog,v 1.96 2015/02/20 18:53:55 vapier Exp $
+
+ 20 Feb 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/imaging-1.1.7-no-host-paths.patch, imaging-1.1.7-r5.ebuild:
+ Fix from Chromium OS for cross-compiling.
30 Dec 2014; Mike Gilbert <floppym@gentoo.org> -imaging-1.1.7-r4.ebuild,
imaging-1.1.7-r1.ebuild, imaging-1.1.7-r2.ebuild, imaging-1.1.7-r5.ebuild:
diff --git a/dev-python/imaging/files/imaging-1.1.7-no-host-paths.patch b/dev-python/imaging/files/imaging-1.1.7-no-host-paths.patch
new file mode 100644
index 000000000000..a84c032450cf
--- /dev/null
+++ b/dev-python/imaging/files/imaging-1.1.7-no-host-paths.patch
@@ -0,0 +1,29 @@
+do not poke around /usr/include and /usr/lib directly as it's (1) not needed
+and (2) breaks cross-compiling
+
+patch from Chromium OS
+
+--- a/setup.py
++++ b/setup.py
+@@ -147,7 +147,6 @@ class pil_build_ext(build_ext):
+ add_directory(library_dirs, "/opt/local/lib")
+ add_directory(include_dirs, "/opt/local/include")
+
+- add_directory(library_dirs, "/usr/local/lib")
+ # FIXME: check /opt/stuff directories here?
+
+ prefix = sysconfig.get_config_var("prefix")
+@@ -207,13 +206,6 @@ class pil_build_ext(build_ext):
+ if os.path.isfile(os.path.join(tcl_dir, "tk.h")):
+ add_directory(include_dirs, tcl_dir)
+
+- # standard locations
+- add_directory(library_dirs, "/usr/local/lib")
+- add_directory(include_dirs, "/usr/local/include")
+-
+- add_directory(library_dirs, "/usr/lib")
+- add_directory(include_dirs, "/usr/include")
+-
+ #
+ # insert new dirs *before* default libs, to avoid conflicts
+ # between Python PYD stub libs and real libraries
diff --git a/dev-python/imaging/imaging-1.1.7-r5.ebuild b/dev-python/imaging/imaging-1.1.7-r5.ebuild
index 86745a28cac7..a816ab87863e 100644
--- a/dev-python/imaging/imaging-1.1.7-r5.ebuild
+++ b/dev-python/imaging/imaging-1.1.7-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.7-r5.ebuild,v 1.2 2014/12/30 18:23:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.7-r5.ebuild,v 1.3 2015/02/20 18:53:55 vapier Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -42,6 +42,7 @@ python_prepare_all() {
"${FILESDIR}/${P}-missing-math.patch"
"${FILESDIR}/${P}-ft-header-include.patch"
"${FILESDIR}/${P}-dont-run-multiple-viewers.patch"
+ "${FILESDIR}/${P}-no-host-paths.patch"
)
# Add shebangs.