summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-07-03 17:19:54 +0000
committerIan Delaney <idella4@gentoo.org>2014-07-03 17:19:54 +0000
commit6ccbf52a16e7a8f7437c7d59a407370ede500e44 (patch)
treee89fd3edbfb0026d413bf8c6c6851b15f49e5766 /dev-python
parent[QA] EAPI bump, remove old wrt bug 334597 (diff)
downloadgentoo-2-6ccbf52a16e7a8f7437c7d59a407370ede500e44.tar.gz
gentoo-2-6ccbf52a16e7a8f7437c7d59a407370ede500e44.tar.bz2
gentoo-2-6ccbf52a16e7a8f7437c7d59a407370ede500e44.zip
add py3.4, update deps, test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/weasyprint/ChangeLog5
-rw-r--r--dev-python/weasyprint/weasyprint-0.22.ebuild26
2 files changed, 11 insertions, 20 deletions
diff --git a/dev-python/weasyprint/ChangeLog b/dev-python/weasyprint/ChangeLog
index 2a3040ab5bc2..92cc950b4346 100644
--- a/dev-python/weasyprint/ChangeLog
+++ b/dev-python/weasyprint/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/weasyprint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/ChangeLog,v 1.9 2014/05/22 03:48:04 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/ChangeLog,v 1.10 2014/07/03 17:19:54 idella4 Exp $
+
+ 03 Jul 2014; Ian Delaney <idella4@gentoo.org> weasyprint-0.22.ebuild:
+ add py3.4, update deps, test phase
22 May 2014; Ian Delaney <idella4@gentoo.org> weasyprint-0.22.ebuild:
adding of py3.4 support held back, upgraded deps, add test phase with failing
diff --git a/dev-python/weasyprint/weasyprint-0.22.ebuild b/dev-python/weasyprint/weasyprint-0.22.ebuild
index e70d873010f6..5ce61c4c922e 100644
--- a/dev-python/weasyprint/weasyprint-0.22.ebuild
+++ b/dev-python/weasyprint/weasyprint-0.22.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/weasyprint-0.22.ebuild,v 1.2 2014/05/22 03:48:04 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/weasyprint-0.22.ebuild,v 1.3 2014/07/03 17:19:54 idella4 Exp $
EAPI="5"
-# py3.4 support pending
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
inherit distutils-r1
@@ -20,9 +20,8 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
# Note: specific subslot of pango since it inlines some of pango headers.
-#cffi>=0.6
RDEPEND="x11-libs/pango:0/0
- >=media-gfx/cairosvg-0.4.1[${PYTHON_USEDEP}]
+ >=media-gfx/cairosvg-1.0.7[${PYTHON_USEDEP}]
>=dev-python/html5lib-0.999[${PYTHON_USEDEP}]
dev-python/cffi:=[${PYTHON_USEDEP}]
>=dev-python/lxml-3.0[${PYTHON_USEDEP}]
@@ -30,25 +29,14 @@ RDEPEND="x11-libs/pango:0/0
~dev-python/tinycss-0.3[${PYTHON_USEDEP}]
>=dev-python/cssselect-0.6[${PYTHON_USEDEP}]
>=dev-python/pyphen-0.8[${PYTHON_USEDEP}]"
- # x11-libs/gdk-pixbuf # optional dep
+# x11-libs/gdk-pixbuf # optional dep
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}] )"
+ dev-python/pytest[${PYTHON_USEDEP}]
+ media-fonts/ahem )"
S="${WORKDIR}/${MY_P}"
-python_prepare_all() {
- # https://github.com/Kozea/WeasyPrint/issues/195
- sed -e s':test_annotate_document:_&:' -e s':test_units:_&:' \
- -i ${PN}/tests/test_css.py || die
- sed -e 's:test_images:_&:' -i ${PN}/tests/test_draw.py || die
- sed -e 's:test_vertical_align:_&:' -e s':test_preferred_widths:_&:' \
- -e 's:test_overflow_wrap:_&:' \
- -i ${PN}/tests/test_layout.py || die
-
- distutils-r1_python_prepare_all
-}
-
python_test() {
py.test || die "testsuite failed under ${EPYTHON}"
}