summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-12-10 11:07:00 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-12-10 11:07:00 +0000
commit651e755d84d7814e59bf28753d873d1a7571d23d (patch)
tree43beb87e4cc2a3d7f4dc5d99a2bc16825676d042 /dev-python
parentChange package license, wrt bug #444626 (diff)
downloadgentoo-2-651e755d84d7814e59bf28753d873d1a7571d23d.tar.gz
gentoo-2-651e755d84d7814e59bf28753d873d1a7571d23d.tar.bz2
gentoo-2-651e755d84d7814e59bf28753d873d1a7571d23d.zip
Version bump, remove old.
(Portage version: 2.2.0_alpha147/cvs/Linux x86_64, signed Manifest commit with key 17A85C72)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/ChangeLog9
-rw-r--r--dev-python/sip/files/sip-4.12.3-python-3.2.patch90
-rw-r--r--dev-python/sip/files/sip-4.12.3-sip_api_is_py_method.patch17
-rw-r--r--dev-python/sip/sip-4.14.2.ebuild (renamed from dev-python/sip/sip-4.14.ebuild)19
4 files changed, 20 insertions, 115 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 487bfbdcb9e6..4743807d7356 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.232 2012/11/22 21:31:43 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.233 2012/12/10 11:06:59 pesa Exp $
+
+*sip-4.14.2 (10 Dec 2012)
+
+ 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +sip-4.14.2.ebuild,
+ -files/sip-4.12.3-python-3.2.patch,
+ -files/sip-4.12.3-sip_api_is_py_method.patch, -sip-4.14.ebuild:
+ Version bump, remove old.
22 Nov 2012; Markus Meier <maekke@gentoo.org> sip-4.13.3.ebuild:
arm stable, bug #435074
diff --git a/dev-python/sip/files/sip-4.12.3-python-3.2.patch b/dev-python/sip/files/sip-4.12.3-python-3.2.patch
deleted file mode 100644
index b0bdaed021c9..000000000000
--- a/dev-python/sip/files/sip-4.12.3-python-3.2.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-http://www.riverbankcomputing.co.uk/hg/sip/rev/3d0336c32dfa
-http://www.riverbankcomputing.co.uk/hg/sip/rev/df42f6bf92c8
-
---- siplib/sip.h.in
-+++ siplib/sip.h.in
-@@ -1553,9 +1553,13 @@
-
- #define sipIsExactWrappedType(wt) (sipTypeAsPyTypeObject((wt)->type) == (PyTypeObject *)(wt))
-
--#define sipConvertFromSliceObject(o,len,start,stop,step,slen) \
-+#if PY_VERSION_HEX >= 0x03020000
-+#define sipConvertFromSliceObject PySlice_GetIndicesEx
-+#else
-+#define sipConvertFromSliceObject(o, len, start, stop, step, slen) \
- PySlice_GetIndicesEx((PySliceObject *)(o), (len), (start), (stop), \
- (step), (slen))
-+#endif
-
-
- /*
---- siplib/siplib.c.in
-+++ siplib/siplib.c.in
-@@ -9216,9 +9216,9 @@
- const sipClassTypeDef *ctd;
-
- if ((ptr = getPtrTypeDef(self, &ctd)) == NULL)
-- return -1;
-+ return;
-
-- return ctd->ctd_releasebuffer((PyObject *)self, ptr, buf);
-+ ctd->ctd_releasebuffer((PyObject *)self, ptr, buf);
- }
- #endif
-
-@@ -10686,7 +10686,11 @@
- if ((wc = sip_api_malloc(ulen * sizeof (wchar_t))) == NULL)
- return -1;
-
-+#if PY_VERSION_HEX >= 0x03020000
-+ ulen = PyUnicode_AsWideChar(obj, wc, ulen);
-+#else
- ulen = PyUnicode_AsWideChar((PyUnicodeObject *)obj, wc, ulen);
-+#endif
-
- if (ulen < 0)
- {
-@@ -10737,7 +10741,11 @@
- if (PyUnicode_GET_SIZE(obj) != 1)
- return -1;
-
-+#if PY_VERSION_HEX >= 0x03020000
-+ if (PyUnicode_AsWideChar(obj, ap, 1) != 1)
-+#else
- if (PyUnicode_AsWideChar((PyUnicodeObject *)obj, ap, 1) != 1)
-+#endif
- return -1;
-
- return 0;
-@@ -10793,7 +10801,11 @@
- if ((wc = sip_api_malloc((ulen + 1) * sizeof (wchar_t))) == NULL)
- return -1;
-
-+#if PY_VERSION_HEX >= 0x03020000
-+ ulen = PyUnicode_AsWideChar(obj, wc, ulen);
-+#else
- ulen = PyUnicode_AsWideChar((PyUnicodeObject *)obj, wc, ulen);
-+#endif
-
- if (ulen < 0)
- {
---- siplib/voidptr.c
-+++ siplib/voidptr.c
-@@ -429,7 +429,7 @@
- {
- Py_ssize_t start, stop, step, slicelength;
-
-- if (PySlice_GetIndicesEx((PySliceObject *)key, v->size, &start, &stop, &step, &slicelength) < 0)
-+ if (sipConvertFromSliceObject(key, v->size, &start, &stop, &step, &slicelength) < 0)
- return NULL;
-
- if (step != 1)
-@@ -486,7 +486,7 @@
- {
- Py_ssize_t stop, step;
-
-- if (PySlice_GetIndicesEx((PySliceObject *)key, v->size, &start, &stop, &step, &size) < 0)
-+ if (sipConvertFromSliceObject(key, v->size, &start, &stop, &step, &size) < 0)
- return -1;
-
- if (step != 1)
diff --git a/dev-python/sip/files/sip-4.12.3-sip_api_is_py_method.patch b/dev-python/sip/files/sip-4.12.3-sip_api_is_py_method.patch
deleted file mode 100644
index 825e943d7cf1..000000000000
--- a/dev-python/sip/files/sip-4.12.3-sip_api_is_py_method.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-http://www.riverbankcomputing.co.uk/hg/sip/rev/f9f4b161c940
-
---- siplib/siplib.c.in
-+++ siplib/siplib.c.in
-@@ -7604,9 +7604,10 @@
- #endif
-
- /*
-- * Check any possible reimplementation is not the wrapped C++ method.
-+ * Check any possible reimplementation is not the wrapped C++ method or
-+ * a default special method implementation..
- */
-- if (cls_dict != NULL && (cls_attr = PyDict_GetItem(cls_dict, mname_obj)) != NULL && Py_TYPE(cls_attr) != &sipMethodDescr_Type)
-+ if (cls_dict != NULL && (cls_attr = PyDict_GetItem(cls_dict, mname_obj)) != NULL && Py_TYPE(cls_attr) != &sipMethodDescr_Type && Py_TYPE(cls_attr) != &PyWrapperDescr_Type)
- {
- reimp = cls_attr;
- break;
diff --git a/dev-python/sip/sip-4.14.ebuild b/dev-python/sip/sip-4.14.2.ebuild
index 2f6649036a91..369db3b913c2 100644
--- a/dev-python/sip/sip-4.14.ebuild
+++ b/dev-python/sip/sip-4.14.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.14.ebuild,v 1.5 2012/11/22 21:31:43 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.14.2.ebuild,v 1.1 2012/12/10 11:06:59 pesa Exp $
EAPI="5"
PYTHON_DEPEND="*"
@@ -63,28 +63,33 @@ src_prepare() {
fi
epatch "${FILESDIR}"/${PN}-4.9.3-darwin.patch
- sed -i -e 's/-O2//g' specs/* || die
python_src_prepare
}
src_configure() {
configuration() {
- local myconf=("$(PYTHON)"
- configure.py
+ local myconf=(
+ "$(PYTHON)" configure.py
--bindir="${EPREFIX}/usr/bin"
--destdir="${EPREFIX}$(python_get_sitedir)"
--incdir="${EPREFIX}$(python_get_includedir)"
--sipdir="${EPREFIX}/usr/share/sip"
$(use debug && echo --debug)
+ AR="$(tc-getAR) cqs"
CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ CFLAGS_RELEASE=
CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS}"
+ CXXFLAGS_RELEASE=
LINK="$(tc-getCXX)"
LINK_SHLIB="$(tc-getCXX)"
- CFLAGS="${CFLAGS}"
- CXXFLAGS="${CXXFLAGS}"
LFLAGS="${LDFLAGS}"
- STRIP=":")
+ LFLAGS_RELEASE=
+ RANLIB=
+ STRIP=
+ )
echo "${myconf[@]}"
"${myconf[@]}"
}