summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-01 17:29:19 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-01 17:29:19 +0000
commit6270ce5836cc41cee56ba00e049943395bbc319d (patch)
tree05f67bcc86b940a61a0c24eba7e82efa979b729a /dev-python
parentVersion bump, bug #287320 (diff)
downloadgentoo-2-6270ce5836cc41cee56ba00e049943395bbc319d.tar.gz
gentoo-2-6270ce5836cc41cee56ba00e049943395bbc319d.tar.bz2
gentoo-2-6270ce5836cc41cee56ba00e049943395bbc319d.zip
Version bump.
(Portage version: 14771-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/setuptools/ChangeLog8
-rw-r--r--dev-python/setuptools/setuptools-0.6.7.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/setuptools/ChangeLog b/dev-python/setuptools/ChangeLog
index 12be5d7fcc1e..165c0302d912 100644
--- a/dev-python/setuptools/ChangeLog
+++ b/dev-python/setuptools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/setuptools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.77 2009/10/29 15:28:29 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.78 2009/11/01 17:29:19 arfrever Exp $
+
+*setuptools-0.6.7 (01 Nov 2009)
+
+ 01 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +setuptools-0.6.7.ebuild:
+ Version bump.
29 Oct 2009; Markus Meier <maekke@gentoo.org> setuptools-0.6.4.ebuild:
amd64/x86 stable, bug #289312
diff --git a/dev-python/setuptools/setuptools-0.6.7.ebuild b/dev-python/setuptools/setuptools-0.6.7.ebuild
new file mode 100644
index 000000000000..8f4a59f95bb9
--- /dev/null
+++ b/dev-python/setuptools/setuptools-0.6.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.7.ebuild,v 1.1 2009/11/01 17:29:19 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="Easily download, build, install, upgrade, and uninstall Python packages. Distribute is a fork of the Setuptools project."
+HOMEPAGE="http://pypi.python.org/pypi/distribute"
+SRC_URI="http://pypi.python.org/packages/source/d/distribute/distribute-${PV}.tar.gz"
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/distribute-${PV}"
+
+DOCS="README.txt docs/easy_install.txt docs/pkg_resources.txt docs/setuptools.txt"
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${PN}-0.6_rc7-noexe.patch"
+
+ # Remove tests that access the network (bugs #198312, #191117)
+ rm setuptools/tests/test_packageindex.py
+
+ sed -e 's:if copied and outf.endswith(".py"):& and outf not in ("build/src/distribute_setup.py", "build/src/distribute_setup_3k.py"):' -i setup.py || die "sed failed"
+}
+
+src_test() {
+ tests() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" test
+ }
+ python_execute_function tests
+}
+
+pkg_preinst() {
+ # Delete unneeded files which cause problems. These files were created by some older, broken versions.
+ if has_version "<dev-python/setuptools-0.6.3-r2"; then
+ rm -fr "${ROOT}"usr/lib*/python*/site-packages/{,._cfg????_}setuptools-*egg-info* || die "Deletion of broken files failed"
+ fi
+}