summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-10 17:52:22 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-10 17:52:22 +0000
commit5f05c21f25a72e37075f38874ed568e3341f41a4 (patch)
treec7692e34ce6aab97004d0651d3557c2d5bff18a2 /dev-python
parentFix use flags & configure, thanks to mr_bones. (diff)
downloadgentoo-2-5f05c21f25a72e37075f38874ed568e3341f41a4.tar.gz
gentoo-2-5f05c21f25a72e37075f38874ed568e3341f41a4.tar.bz2
gentoo-2-5f05c21f25a72e37075f38874ed568e3341f41a4.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 15816-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/werkzeug/ChangeLog6
-rw-r--r--dev-python/werkzeug/werkzeug-0.6.ebuild19
2 files changed, 15 insertions, 10 deletions
diff --git a/dev-python/werkzeug/ChangeLog b/dev-python/werkzeug/ChangeLog
index dee1cf626d3d..3793cc053db5 100644
--- a/dev-python/werkzeug/ChangeLog
+++ b/dev-python/werkzeug/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/werkzeug
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.14 2010/02/21 11:31:10 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.15 2010/03/10 17:52:22 arfrever Exp $
+
+ 10 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ werkzeug-0.6.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*werkzeug-0.6 (21 Feb 2010)
diff --git a/dev-python/werkzeug/werkzeug-0.6.ebuild b/dev-python/werkzeug/werkzeug-0.6.ebuild
index 77a68ad569a6..ce2576902813 100644
--- a/dev-python/werkzeug/werkzeug-0.6.ebuild
+++ b/dev-python/werkzeug/werkzeug-0.6.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/werkzeug-0.6.ebuild,v 1.1 2010/02/21 11:31:10 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/werkzeug-0.6.ebuild,v 1.2 2010/03/10 17:52:22 arfrever Exp $
-NEED_PYTHON="2.4"
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -11,27 +14,25 @@ MY_P="Werkzeug-${PV}"
DESCRIPTION="Collection of various utilities for WSGI applications"
HOMEPAGE="http://werkzeug.pocoo.org/"
SRC_URI="http://pypi.python.org/packages/source/W/Werkzeug/${MY_P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="test"
RDEPEND=""
-DEPEND=">=dev-python/setuptools-0.6_rc5
+DEPEND="dev-python/setuptools
app-arch/unzip
test? ( dev-python/py
dev-python/lxml
dev-python/nose
dev-python/simplejson )"
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
-src_install() {
- DOCS="CHANGES"
- distutils_src_install
-}
+DOCS="CHANGES"
src_test() {
- distutils_python_version
- make test || die "tests failed"
+ distutils_src_test -e '^test_app$'
}