summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-05-08 11:42:11 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-05-08 11:42:11 +0000
commit58f9e07c59351ba7b296f55833505f2ab4a74dd1 (patch)
treeed81ef772d65b6c56d7e2dc5d625b86829a50994 /dev-python
parentMigrate to virtual/pkgconfig. (diff)
downloadgentoo-2-58f9e07c59351ba7b296f55833505f2ab4a74dd1.tar.gz
gentoo-2-58f9e07c59351ba7b296f55833505f2ab4a74dd1.tar.bz2
gentoo-2-58f9e07c59351ba7b296f55833505f2ab4a74dd1.zip
Version bump, fixes #415113. Thanks to Ian Delaney <johneed@hotmail.com> for report and testing
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/colander/ChangeLog9
-rw-r--r--dev-python/colander/colander-0.9.3.ebuild53
-rw-r--r--dev-python/colander/colander-0.9.4.ebuild53
-rw-r--r--dev-python/colander/colander-0.9.8.ebuild (renamed from dev-python/colander/colander-0.9.6.ebuild)36
4 files changed, 32 insertions, 119 deletions
diff --git a/dev-python/colander/ChangeLog b/dev-python/colander/ChangeLog
index 6c85f7929419..3e82ec2b8550 100644
--- a/dev-python/colander/ChangeLog
+++ b/dev-python/colander/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/colander
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/ChangeLog,v 1.4 2012/04/08 19:33:43 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/ChangeLog,v 1.5 2012/05/08 11:42:11 xarthisius Exp $
+
+*colander-0.9.8 (08 May 2012)
+
+ 08 May 2012; Kacper Kowalik <xarthisius@gentoo.org> +colander-0.9.8.ebuild,
+ -colander-0.9.3.ebuild, -colander-0.9.4.ebuild, -colander-0.9.6.ebuild:
+ Version bump, fixes #415113. Thanks to Ian Delaney <johneed@hotmail.com> for
+ report and testing
*colander-0.9.7 (08 Apr 2012)
diff --git a/dev-python/colander/colander-0.9.3.ebuild b/dev-python/colander/colander-0.9.3.ebuild
deleted file mode 100644
index 4fa8b0935a73..000000000000
--- a/dev-python/colander/colander-0.9.3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/colander-0.9.3.ebuild,v 1.1 2011/07/30 01:43:51 rafaelmartins Exp $
-
-EAPI=3
-
-SUPPORT_PYTHON_ABIS=1
-PYTHON_DEPEND="2"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils
-
-DESCRIPTION="A simple schema-based serialization and deserialization library"
-HOMEPAGE="http://docs.repoze.org/colander http://pypi.python.org/pypi/colander"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="repoze"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/translationstring
- dev-python/iso8601"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-src_prepare() {
- distutils_src_prepare
-
- # fix sphinx theme. pylons theme not include in source
- sed -i -e 's/pylons/default/' docs/conf.py || die 'sed failed.'
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd docs
- mkdir _themes
- emake html || die "make html failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "dohtml failed"
- fi
-}
diff --git a/dev-python/colander/colander-0.9.4.ebuild b/dev-python/colander/colander-0.9.4.ebuild
deleted file mode 100644
index 7453d0a3b0fb..000000000000
--- a/dev-python/colander/colander-0.9.4.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/colander-0.9.4.ebuild,v 1.1 2012/02/07 08:03:54 patrick Exp $
-
-EAPI=3
-
-SUPPORT_PYTHON_ABIS=1
-PYTHON_DEPEND="2"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils
-
-DESCRIPTION="A simple schema-based serialization and deserialization library"
-HOMEPAGE="http://docs.repoze.org/colander http://pypi.python.org/pypi/colander"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="repoze"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/translationstring
- dev-python/iso8601"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-src_prepare() {
- distutils_src_prepare
-
- # fix sphinx theme. pylons theme not include in source
- sed -i -e 's/pylons/default/' docs/conf.py || die 'sed failed.'
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd docs
- mkdir _themes
- emake html || die "make html failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "dohtml failed"
- fi
-}
diff --git a/dev-python/colander/colander-0.9.6.ebuild b/dev-python/colander/colander-0.9.8.ebuild
index 96feee028f2c..aa5022b6cff1 100644
--- a/dev-python/colander/colander-0.9.6.ebuild
+++ b/dev-python/colander/colander-0.9.8.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/colander-0.9.6.ebuild,v 1.1 2012/02/22 23:42:21 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/colander-0.9.8.ebuild,v 1.1 2012/05/08 11:42:11 xarthisius Exp $
EAPI=4
SUPPORT_PYTHON_ABIS=1
PYTHON_DEPEND="2:2.6 3:3.2"
RESTRICT_PYTHON_ABIS="2.4 2.5 3.0 3.1"
-DISTUTILS_SRC_TEST="setup.py"
+DISTUTILS_SRC_TEST=nosetests
inherit distutils
@@ -19,26 +19,38 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="repoze MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="doc"
# Depend on an ebuild of translationstring with Python 3 support.
RDEPEND=">=dev-python/translationstring-1.1"
DEPEND="${RDEPEND}
- dev-python/setuptools"
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
# Include COPYRIGHT.txt because the license seems to require it.
DOCS="CHANGES.txt COPYRIGHT.txt README.txt"
+src_prepare() {
+ distutils_src_prepare
+
+ # Remove pylons theme since it's not included in source
+ sed -e "/# Add and use Pylons theme/,+37d" -i docs/conf.py || die
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ # https://github.com/Pylons/colander/issues/38
+ PYTHONPATH="." emake -C docs html SPHINXOPTS=""
+ fi
+}
+
src_install() {
distutils_src_install
- # The docs do not currently build for me and depend on a theme
- # only available from git that contains hardcoded references
- # to files on https://static.pylonsproject.org/ (so the docs
- # would not actually work offline). Include the source, which
- # is at least somewhat readable.
-
- docinto docs
- dodoc docs/*.rst
+ if use doc; then
+ dohtml -A inv -r docs/_build/html/
+ fi
}