summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-01-15 16:42:13 +0000
committerIan Delaney <idella4@gentoo.org>2013-01-15 16:42:13 +0000
commit5751532fecc17305b6d7f7945d6f42fea992bfa6 (patch)
tree8a6a52e8cda23479909180cdf8159154d9b45473 /dev-python
parentVersion bump. Remove old. (diff)
downloadgentoo-2-5751532fecc17305b6d7f7945d6f42fea992bfa6.tar.gz
gentoo-2-5751532fecc17305b6d7f7945d6f42fea992bfa6.tar.bz2
gentoo-2-5751532fecc17305b6d7f7945d6f42fea992bfa6.zip
0.1.6 migrated to distutils-r1 eclass, requested by kensington
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyasn1/ChangeLog5
-rw-r--r--dev-python/pyasn1/pyasn1-0.1.6.ebuild20
2 files changed, 12 insertions, 13 deletions
diff --git a/dev-python/pyasn1/ChangeLog b/dev-python/pyasn1/ChangeLog
index a54df6995830..6f3cf370c47f 100644
--- a/dev-python/pyasn1/ChangeLog
+++ b/dev-python/pyasn1/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pyasn1
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyasn1/ChangeLog,v 1.44 2013/01/08 15:56:20 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyasn1/ChangeLog,v 1.45 2013/01/15 16:42:13 idella4 Exp $
+
+ 15 Jan 2013; Ian Delaney <idella4@gentoo.org> pyasn1-0.1.6.ebuild:
+ 0.1.6 migrated to distutils-r1 eclass, requested by kensington
*pyasn1-0.1.6 (09 Jan 2013)
diff --git a/dev-python/pyasn1/pyasn1-0.1.6.ebuild b/dev-python/pyasn1/pyasn1-0.1.6.ebuild
index 45673f33205a..4eca8b0fe3a8 100644
--- a/dev-python/pyasn1/pyasn1-0.1.6.ebuild
+++ b/dev-python/pyasn1/pyasn1-0.1.6.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyasn1/pyasn1-0.1.6.ebuild,v 1.1 2013/01/08 15:56:20 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyasn1/pyasn1-0.1.6.ebuild,v 1.2 2013/01/15 16:42:13 idella4 Exp $
-EAPI="4"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} pypy{1_9,2_0} )
-inherit distutils
+inherit distutils-r1
DESCRIPTION="ASN.1 library for Python"
HOMEPAGE="http://pyasn1.sourceforge.net/ http://pypi.python.org/pypi/pyasn1"
@@ -17,18 +16,15 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="doc"
-DEPEND="dev-python/setuptools"
RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib:." "$(PYTHON)" test/suite.py
- }
- python_execute_function testing
+python_test() {
+ "${PYTHON}" test/suite.py
}
src_install() {
- distutils_src_install
+ distutils-r1_src_install
if use doc; then
dohtml doc/*