summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-24 14:54:42 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-24 14:54:42 +0000
commit55c65bbe9b6c31f48e6aa62f6a753fadbaa9e9bc (patch)
tree200abf246b453b1dbf63f1e3f242c4a6dae1dc74 /dev-python
parentbump to 2.3.0, change RDEPEND to DEPEND and vice-versa. Add libnotify USE flag (diff)
downloadgentoo-2-55c65bbe9b6c31f48e6aa62f6a753fadbaa9e9bc.tar.gz
gentoo-2-55c65bbe9b6c31f48e6aa62f6a753fadbaa9e9bc.tar.bz2
gentoo-2-55c65bbe9b6c31f48e6aa62f6a753fadbaa9e9bc.zip
fix python eclass use, bug #207667
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/notify-python/ChangeLog8
-rw-r--r--dev-python/notify-python/notify-python-0.1.1.ebuild23
2 files changed, 27 insertions, 4 deletions
diff --git a/dev-python/notify-python/ChangeLog b/dev-python/notify-python/ChangeLog
index 8d9f9ea6a8f8..1396833ff026 100644
--- a/dev-python/notify-python/ChangeLog
+++ b/dev-python/notify-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/notify-python
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/ChangeLog,v 1.6 2007/12/22 14:00:16 dertobi123 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/ChangeLog,v 1.7 2008/02/24 14:54:42 eva Exp $
+
+ 24 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ notify-python-0.1.1.ebuild:
+ fix python eclass use, bug #207667
22 Dec 2007; Tobias Scherbaum <dertobi123@gentoo.org>
notify-python-0.1.1.ebuild:
diff --git a/dev-python/notify-python/notify-python-0.1.1.ebuild b/dev-python/notify-python/notify-python-0.1.1.ebuild
index 13794fc2645b..5818f3f18cc8 100644
--- a/dev-python/notify-python/notify-python-0.1.1.ebuild
+++ b/dev-python/notify-python/notify-python-0.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/notify-python-0.1.1.ebuild,v 1.6 2007/12/22 14:00:16 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/notify-python-0.1.1.ebuild,v 1.7 2008/02/24 14:54:42 eva Exp $
NEED_PYTHON=2.3.5
@@ -20,7 +20,26 @@ RDEPEND=">=dev-python/pygtk-2.4.0
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README
}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0/pynotify
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0/pynotify
+}