summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-01-16 08:33:23 +0000
committerIan Delaney <idella4@gentoo.org>2013-01-16 08:33:23 +0000
commit5550555d602ab0533e284ec32c9676102f50f280 (patch)
treeeb45c30146e5ed216638b5a97fc2dc9a919256e1 /dev-python
parentFix compability with libcdio-paranoia. (diff)
downloadgentoo-2-5550555d602ab0533e284ec32c9676102f50f280.tar.gz
gentoo-2-5550555d602ab0533e284ec32c9676102f50f280.tar.bz2
gentoo-2-5550555d602ab0533e284ec32c9676102f50f280.zip
bump, this version supports only py2, closes Bug 449528
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/chardet/ChangeLog10
-rw-r--r--dev-python/chardet/chardet-2.1.1.ebuild28
2 files changed, 35 insertions, 3 deletions
diff --git a/dev-python/chardet/ChangeLog b/dev-python/chardet/ChangeLog
index b72d5413cd6b..875c1410bf4b 100644
--- a/dev-python/chardet/ChangeLog
+++ b/dev-python/chardet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/chardet
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chardet/ChangeLog,v 1.20 2010/05/11 21:04:07 ranger Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chardet/ChangeLog,v 1.21 2013/01/16 08:33:23 idella4 Exp $
+
+*chardet-2.1.1 (16 Jan 2013)
+
+ 16 Jan 2013; Ian Delaney <idella4@gentoo.org> +chardet-2.1.1.ebuild:
+ bump, this version supports only py2, closes Bug 449528
11 May 2010; Brent Baude <ranger@gentoo.org> chardet-2.0.1.ebuild:
stable ppc64, bug 305183
@@ -71,4 +76,3 @@
01 Dec 2006; Steve Dibb <beandog@gentoo.org> +metadata.xml,
+chardet-1.0.ebuild:
Initial import, bug 138324, thanks to Zhang Le
-
diff --git a/dev-python/chardet/chardet-2.1.1.ebuild b/dev-python/chardet/chardet-2.1.1.ebuild
new file mode 100644
index 000000000000..f009a4895fe0
--- /dev/null
+++ b/dev-python/chardet/chardet-2.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chardet/chardet-2.1.1.ebuild,v 1.1 2013/01/16 08:33:23 idella4 Exp $
+
+EAPI="4"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Character encoding auto-detection in Python."
+HOMEPAGE="http://chardet.feedparser.org/ http://code.google.com/p/chardet/"
+SRC_URI="mirror//pypi/c/chardet/chardet-2.1.1.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r "${S}/docs/"
+ python_convert_shebangs -r 2 .
+}