summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2012-11-07 12:23:31 +0000
committerIan Delaney <idella4@gentoo.org>2012-11-07 12:23:31 +0000
commit545856e2694ca765fd6606b5eea2cd4a74ef675f (patch)
tree620579742acada31f877e78cb73f36f983b1c962 /dev-python
parentstable ppc ppc64, bug #441310 (diff)
downloadgentoo-2-545856e2694ca765fd6606b5eea2cd4a74ef675f.tar.gz
gentoo-2-545856e2694ca765fd6606b5eea2cd4a74ef675f.tar.bz2
gentoo-2-545856e2694ca765fd6606b5eea2cd4a74ef675f.zip
Added patch to rem broken tests, test restricts to python2.[56]
(Portage version: 2.1.11.30/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/guppy/ChangeLog7
-rw-r--r--dev-python/guppy/files/guppy-0.1.9-rm_BrokenTests.patch57
-rw-r--r--dev-python/guppy/guppy-0.1.9-r2.ebuild6
3 files changed, 66 insertions, 4 deletions
diff --git a/dev-python/guppy/ChangeLog b/dev-python/guppy/ChangeLog
index 2ac3dad9d120..a71d6754fecd 100644
--- a/dev-python/guppy/ChangeLog
+++ b/dev-python/guppy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/guppy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/guppy/ChangeLog,v 1.16 2012/02/20 15:19:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/guppy/ChangeLog,v 1.17 2012/11/07 12:23:30 idella4 Exp $
+
+ 08 Nov 2012; Ian Delaney <idella4@gentoo.org>
+ +files/guppy-0.1.9-rm_BrokenTests.patch, guppy-0.1.9-r2.ebuild:
+ Added patch to rem broken tests, test restricts to python2.[56]
20 Feb 2012; Patrick Lauer <patrick@gentoo.org> guppy-0.1.9-r2.ebuild,
guppy-0.1.9.ebuild:
@@ -71,4 +75,3 @@
24 Mar 2006; Marien Zwart <marienz@gentoo.org>
+files/guppy-0.1.3-skip-tests.patch, +metadata.xml, +guppy-0.1.3.ebuild:
New ebuild.
-
diff --git a/dev-python/guppy/files/guppy-0.1.9-rm_BrokenTests.patch b/dev-python/guppy/files/guppy-0.1.9-rm_BrokenTests.patch
new file mode 100644
index 000000000000..fabbe4cda512
--- /dev/null
+++ b/dev-python/guppy/files/guppy-0.1.9-rm_BrokenTests.patch
@@ -0,0 +1,57 @@
+diff -ur guppy-0.1.9.orig/guppy/sets/test.py guppy-0.1.9/guppy/sets/test.py
+--- guppy/sets/test.py 2009-06-23 21:48:32.000000000 +0800
++++ guppy/sets/test.py 2012-11-07 16:59:38.383392670 +0800
+@@ -4,6 +4,11 @@
+ # so wouldn't check so much with python -O.
+
+ import gc, random, sys
++if sys.version_info[:2] == (2, 7):
++ import unittest
++else:
++ import unittest2 as unittest
++
+ try:
+ import numpy.random
+ except ImportError:
+@@ -211,6 +211,7 @@
+
+ '.nython off'
+
++@unittest.skip("Class broken")
+ class Test:
+ faster = 1 # Set to 1 if test should be faster (less exhaustive) than normally
+
+diff -ur guppy-0.1.9.orig/guppy/heapy/test/test_View.py guppy-0.1.9/guppy/heapy/test/test_View.py
+--- guppy/heapy/test/test_View.py 2009-06-12 18:20:53.000000000 +0800
++++ guppy/heapy/test/test_View.py 2012-11-07 17:23:52.289280501 +0800
+@@ -1,4 +1,11 @@
+ from guppy.heapy.test import support
++import sys
++
++if sys.version_info[:2] == (2, 7):
++ import unittest
++else:
++ import unittest2 as unittest
++
+ class TestCase(support.TestCase):
+ def setUp(self):
+ support.TestCase.setUp(self)
+@@ -55,6 +55,7 @@
+ p = iso(z).referents.indisize
+ self.aseq(p, iso(y).indisize)
+
++ @unittest.skip("broken test")
+ def test_horizon(self):
+ iso = self.iso
+ h = self.View.horizon()
+diff -ur guppy-0.1.9.orig/guppy/heapy/test/test_all.py guppy-0.1.9/guppy/heapy/test/test_all.py
+--- guppy/heapy/test/test_all.py 2009-06-18 21:44:11.000000000 +0800
++++ guppy/heapy/test/test_all.py 2012-11-07 17:34:04.036233306 +0800
+@@ -1,7 +1,6 @@
+ import sys
+
+ autotests = (
+- 'dependencies',
+ 'Classifiers',
+ 'heapyc',
+ 'ER',
diff --git a/dev-python/guppy/guppy-0.1.9-r2.ebuild b/dev-python/guppy/guppy-0.1.9-r2.ebuild
index f90e28b5572b..8d0c05d54e22 100644
--- a/dev-python/guppy/guppy-0.1.9-r2.ebuild
+++ b/dev-python/guppy/guppy-0.1.9-r2.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/guppy/guppy-0.1.9-r2.ebuild,v 1.2 2012/02/20 15:18:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/guppy/guppy-0.1.9-r2.ebuild,v 1.3 2012/11/07 12:23:30 idella4 Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+PYTHON_TESTS_RESTRICTED_ABIS="2.[56]"
DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="Guppy-PE -- A Python Programming Environment"
HOMEPAGE="http://guppy-pe.sourceforge.net/ http://pypi.python.org/pypi/guppy"
@@ -27,6 +28,7 @@ PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
DOCS="ANNOUNCE ChangeLog"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-rm_BrokenTests.patch
distutils_src_prepare
preparation() {
if [[ ${PYTHON_ABI} == "2.7" ]]; then