summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-02-14 03:38:41 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-02-14 03:38:41 +0000
commit4d6ad5f05f088008e63602cd16e30854ca7e3c6d (patch)
treeee34f56a9e82724a85d0b0754e3e29ee17ac0f43 /dev-python
parentversion bump to 1.9.3, snapshot from git. With Rich0's blessing. (diff)
downloadgentoo-2-4d6ad5f05f088008e63602cd16e30854ca7e3c6d.tar.gz
gentoo-2-4d6ad5f05f088008e63602cd16e30854ca7e3c6d.tar.bz2
gentoo-2-4d6ad5f05f088008e63602cd16e30854ca7e3c6d.zip
Bump for #402867
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/psycopg/ChangeLog7
-rw-r--r--dev-python/psycopg/psycopg-2.4.4.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/dev-python/psycopg/ChangeLog b/dev-python/psycopg/ChangeLog
index b28088217786..7ab168fd46a7 100644
--- a/dev-python/psycopg/ChangeLog
+++ b/dev-python/psycopg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/psycopg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.139 2012/02/13 19:25:41 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.140 2012/02/14 03:38:41 patrick Exp $
+
+*psycopg-2.4.4 (14 Feb 2012)
+
+ 14 Feb 2012; Patrick Lauer <patrick@gentoo.org> +psycopg-2.4.4.ebuild:
+ Bump for #402867
13 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org> psycopg-2.4.2.ebuild:
ppc64 stable wrt #392749
diff --git a/dev-python/psycopg/psycopg-2.4.4.ebuild b/dev-python/psycopg/psycopg-2.4.4.ebuild
new file mode 100644
index 000000000000..ba2ac3d01637
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.4.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.4.4.ebuild,v 1.1 2012/02/14 03:38:41 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils eutils
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="http://initd.org/psycopg/ http://pypi.python.org/pypi/psycopg2"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="debug doc examples mxdatetime"
+
+RDEPEND=">=dev-db/postgresql-base-8.1
+ mxdatetime? ( dev-python/egenix-mx-base )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="AUTHORS doc/HACKING doc/SUCCESS"
+PYTHON_MODNAME="${PN}2"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.4.2-setup.py.patch"
+ epatch "${FILESDIR}/${PN}-2.0.9-round-solaris.patch"
+
+ python_convert_shebangs 2 doc/src/tools/stitch_text.py
+
+ if use debug; then
+ sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die "sed failed"
+ fi
+
+ if use mxdatetime; then
+ sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die "sed failed"
+ fi
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd doc > /dev/null
+ emake -j1 html text || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodoc doc/psycopg2.txt || die "dodoc failed"
+
+ pushd doc/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Installation of examples failed"
+ fi
+}