summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2012-12-02 02:33:56 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2012-12-02 02:33:56 +0000
commit4a35a7c09addc1cd5298d48f793b9749aa303903 (patch)
treeecb8a7164849d9b6ef38b68d05da530269c86d3b /dev-python
parentMigrate away from sys-fs/udev to virtual/udev with USE dependency for hwdb. (diff)
downloadgentoo-2-4a35a7c09addc1cd5298d48f793b9749aa303903.tar.gz
gentoo-2-4a35a7c09addc1cd5298d48f793b9749aa303903.tar.bz2
gentoo-2-4a35a7c09addc1cd5298d48f793b9749aa303903.zip
Initial version from Phil's maintainership.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pysctp/ChangeLog9
-rw-r--r--dev-python/pysctp/metadata.xml13
-rw-r--r--dev-python/pysctp/pysctp-0.6.ebuild20
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pysctp/ChangeLog b/dev-python/pysctp/ChangeLog
new file mode 100644
index 000000000000..54cb0494705e
--- /dev/null
+++ b/dev-python/pysctp/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/pysctp
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysctp/ChangeLog,v 1.1 2012/12/02 02:33:56 zx2c4 Exp $
+
+*pysctp-0.6 (02 Dec 2012)
+
+ 02 Dec 2012; Jason A. Donenfeld <zx2c4@gentoo.org> +metadata.xml,
+ +pysctp-0.6.ebuild:
+ Initial version from Phil's maintainership.
diff --git a/dev-python/pysctp/metadata.xml b/dev-python/pysctp/metadata.xml
new file mode 100644
index 000000000000..ed765996d6d3
--- /dev/null
+++ b/dev-python/pysctp/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <maintainer>
+ <email>phil@p1sec.com</email>
+ <name>Philippe Langlois</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/dev-python/pysctp/pysctp-0.6.ebuild b/dev-python/pysctp/pysctp-0.6.ebuild
new file mode 100644
index 000000000000..be312687f382
--- /dev/null
+++ b/dev-python/pysctp/pysctp-0.6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysctp/pysctp-0.6.ebuild,v 1.1 2012/12/02 02:33:56 zx2c4 Exp $
+
+EAPI=4
+
+inherit distutils
+
+DESCRIPTION="PySCTP gives access to the SCTP transport protocol from Python."
+HOMEPAGE="https://github.com/philpraxis/pysctp"
+SRC_URI="https://github.com/philpraxis/${PN}/archive/v${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PYTHON_DEPEND="2"
+DEPEND="net-misc/lksctp-tools"
+RDEPEND="${DEPEND}"