summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-11 23:31:26 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-11 23:31:26 +0000
commit46436cd0a7ae268adf07f2753e36cb60a14968c2 (patch)
tree0504eac9c65f7f1089ae5c82f7bd576d070fb5c5 /dev-python
parentNew patchset by Anthony G Basile, based on mainline 2.6.32.15 sources. (diff)
downloadgentoo-2-46436cd0a7ae268adf07f2753e36cb60a14968c2.tar.gz
gentoo-2-46436cd0a7ae268adf07f2753e36cb60a14968c2.tar.bz2
gentoo-2-46436cd0a7ae268adf07f2753e36cb60a14968c2.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycipher/ChangeLog8
-rw-r--r--dev-python/pycipher/pycipher-0.2.ebuild33
2 files changed, 27 insertions, 14 deletions
diff --git a/dev-python/pycipher/ChangeLog b/dev-python/pycipher/ChangeLog
index 42f0caa8613b..e091d1b333ff 100644
--- a/dev-python/pycipher/ChangeLog
+++ b/dev-python/pycipher/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pycipher
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycipher/ChangeLog,v 1.1 2009/02/03 19:55:22 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycipher/ChangeLog,v 1.2 2010/06/11 23:31:26 arfrever Exp $
+
+ 11 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pycipher-0.2.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*pycipher-0.2 (03 Feb 2009)
diff --git a/dev-python/pycipher/pycipher-0.2.ebuild b/dev-python/pycipher/pycipher-0.2.ebuild
index 1313bc20b7d1..2036ae4332f7 100644
--- a/dev-python/pycipher/pycipher-0.2.ebuild
+++ b/dev-python/pycipher/pycipher-0.2.ebuild
@@ -1,11 +1,14 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycipher/pycipher-0.2.ebuild,v 1.1 2009/02/03 19:55:22 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycipher/pycipher-0.2.ebuild,v 1.2 2010/06/11 23:31:26 arfrever Exp $
-inherit eutils python
+EAPI="3"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
-DESCRIPTION="A Python module that implements several well-known classical cipher \
-algorithms"
+inherit python
+
+DESCRIPTION="A Python module that implements several well-known classical cipher algorithms"
HOMEPAGE="http://pycipher.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.py"
@@ -14,15 +17,21 @@ SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE=""
-DEPEND="dev-lang/python"
+DEPEND=""
+RDEPEND=""
src_install() {
- cd "${WORKDIR}"
+ installation() {
+ insinto $(python_get_sitedir)
+ newins "${DISTDIR}/${P}.py" ${PN}.py
+ }
+ python_execute_function installation
+}
- python_version
- exeinto "${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages"
- newexe "${DISTDIR}/${P}.py ${PN}.py"
+pkg_postinst() {
+ python_mod_optimize ${PN}.py
+}
- local dir="${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages"
- make_wrapper "${PN}" "python ./${PN}.py" "${dir}"
+pkg_postrm() {
+ python_mod_cleanup ${PN}.py
}